Patch mcpu to march, since mcpu is deprecated and their usage of mcpu should be march
authorDoug Goldstein <cardoe@gentoo.org>
Mon, 19 Mar 2007 15:49:21 +0000 (15:49 +0000)
committerDoug Goldstein <cardoe@gentoo.org>
Mon, 19 Mar 2007 15:49:21 +0000 (15:49 +0000)
Package-Manager: portage-2.1.2.2

media-tv/mythtv/ChangeLog
media-tv/mythtv/files/mythtv-trunk-mcpu-march.patch [new file with mode: 0644]
media-tv/mythtv/mythtv-0.21_pre12945.ebuild

index 690937d03c2e2742de1c3068d5b7832bbae4d59d..47835aa39b1d2120611fad097ca3e15333fef5a8 100644 (file)
@@ -1,11 +1,11 @@
 # ChangeLog for media-tv/mythtv
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.144 2007/03/19 07:30:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.145 2007/03/19 15:49:21 cardoe Exp $
 
   19 Mar 2007; Doug Goldstein <cardoe@gentoo.org>
   mythtv-0.21_pre12945.ebuild:
   Upstream removed building backend and frontend only support to spite Gentoo
-  users. Remove options that were consolidated into 'iptv'.
+  users. Remove options that were consolidated into 'iptv'. Patch mcpu to march.
 
   19 Mar 2007; Doug Goldstein <cardoe@gentoo.org> mythtv-0.20_p12963.ebuild,
   mythtv-0.20_p13053.ebuild, mythtv-0.21_pre12945.ebuild:
diff --git a/media-tv/mythtv/files/mythtv-trunk-mcpu-march.patch b/media-tv/mythtv/files/mythtv-trunk-mcpu-march.patch
new file mode 100644 (file)
index 0000000..8d3cb19
--- /dev/null
@@ -0,0 +1,79 @@
+--- configure  2007-03-19 03:03:48.000000000 -0400
++++ /home/cardoe/configure.mythtv      2007-03-19 03:19:37.000000000 -0400
+@@ -1766,50 +1766,50 @@
+ if test $tune != "generic"; then
+     case $tune in
+         601|ppc601|PowerPC601)
+-            ARCHFLAGS="-mcpu=601"
++            ARCHFLAGS="-march=601"
+             if test $altivec = "yes"; then
+                 echo "WARNING: Tuning for PPC601 but AltiVec enabled!";
+             fi
+         ;;
+         603*|ppc603*|PowerPC603*)
+-            ARCHFLAGS="-mcpu=603"
++            ARCHFLAGS="-march=603"
+             if test $altivec = "yes"; then
+                 echo "WARNING: Tuning for PPC603 but AltiVec enabled!";
+             fi
+         ;;
+         604*|ppc604*|PowerPC604*)
+-            ARCHFLAGS="-mcpu=604"
++            ARCHFLAGS="-march=604"
+             if test $altivec = "yes"; then
+                 echo "WARNING: Tuning for PPC604 but AltiVec enabled!";
+             fi
+         ;;
+         G3|g3|75*|ppc75*|PowerPC75*)
+-            ARCHFLAGS="-mcpu=750 -mtune=750 -mpowerpc-gfxopt"
++            ARCHFLAGS="-march=750 -mtune=750 -mpowerpc-gfxopt"
+             if test $altivec = "yes"; then
+                 echo "WARNING: Tuning for PPC75x but AltiVec enabled!";
+             fi
+         ;;
+         G4|g4|745*|ppc745*|PowerPC745*)
+-            ARCHFLAGS="-mcpu=7450 -mtune=7450 -mpowerpc-gfxopt"
++            ARCHFLAGS="-march=7450 -mtune=7450 -mpowerpc-gfxopt"
+             if test $altivec = "no"; then
+                 echo "WARNING: Tuning for PPC745x but AltiVec disabled!";
+             fi
+         ;;
+         74*|ppc74*|PowerPC74*)
+-            ARCHFLAGS="-mcpu=7400 -mtune=7400 -mpowerpc-gfxopt"
++            ARCHFLAGS="-march=7400 -mtune=7400 -mpowerpc-gfxopt"
+             if test $altivec = "no"; then
+                 echo "WARNING: Tuning for PPC74xx but AltiVec disabled!";
+             fi
+         ;;
+         G5|g5|970|ppc970|PowerPC970|power4*|Power4*)
+-            ARCHFLAGS="-mcpu=970 -mtune=970 -mpowerpc-gfxopt -mpowerpc64"
++            ARCHFLAGS="-march=970 -mtune=970 -mpowerpc-gfxopt -mpowerpc64"
+             if test $altivec = "no"; then
+                 echo "WARNING: Tuning for PPC970 but AltiVec disabled!";
+             fi
+             POWERPCMODE="64bits"
+         ;;
+         sparc64)
+-            ARCHFLAGS="-mcpu=v9 -mtune=v9"
++            ARCHFLAGS="-march=v9 -mtune=v9"
+         ;;               
+       *)
+             ARCHFLAGS="-mtune=$tune"
+@@ -1818,7 +1818,7 @@
+ fi
+ if test x"$cpu_overide" = x"yes"; then
+-    ARCHFLAGS="-mcpu=$arch_raw $ARCHFLAGS"
++    ARCHFLAGS="-march=$arch_raw $ARCHFLAGS"
+ fi
+ # make sure we can execute files in $TMPDIR
+@@ -2045,7 +2045,7 @@
+ if test x"$tune" = x"generic" -a x"$arch" = x"x86_64" -a x"$cpu_overide" != x"yes"; then
+    ARCHFLAGS="-march=k8"
+ elif test x"$tune" = x"generic" -a x"$arch" = x"sparc64" -a x"$cpu_overide" != x"yes"; then
+-   ARCHFLAGS="-mcpu=ultrasparc -mvis"
++   ARCHFLAGS="-march=ultrasparc -mvis"
+ fi
+ if test x"$proc_error_msg" = x"yes"; then
index b30266c19ef2e1c1a4e8a7bd8dff191b2fe9cba4..c4fcbdb6c60690800a806b5e40e9c7218dcad7ff 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre12945.ebuild,v 1.3 2007/03/19 07:30:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre12945.ebuild,v 1.4 2007/03/19 15:49:21 cardoe Exp $
 
 inherit flag-o-matic multilib eutils qt3 mythtv subversion
 
@@ -95,6 +95,18 @@ pkg_setup() {
        echo
 }
 
+src_unpack() {
+       subversion_src_unpack
+
+       # mcpu to march
+       epatch "${FILESDIR}"/${PN}-trunk-mcpu-march.patch
+
+       # As needed fix since they don't know how to write qmake let alone a real
+       # make system. And they won't accept this upstream since it comes from
+       # Gentoo
+       #epatch "${FILESDIR}"/${PN}-0.20-as-needed.patch
+}
+
 src_compile() {
        local myconf="--prefix=/usr
                --mandir=/usr/share/man