app-emulation/libvirt: add proper python dependencies
authorMatthias Maier <tamiko@gentoo.org>
Sun, 19 Aug 2018 18:34:56 +0000 (13:34 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 19 Aug 2018 18:53:19 +0000 (13:53 -0500)
Closes: https://bugs.gentoo.org/660710
Package-Manager: Portage-2.3.47, Repoman-2.3.10

app-emulation/libvirt/libvirt-4.3.0.ebuild
app-emulation/libvirt/libvirt-4.4.0-r1.ebuild
app-emulation/libvirt/libvirt-4.5.0-r1.ebuild
app-emulation/libvirt/libvirt-4.6.0.ebuild
app-emulation/libvirt/libvirt-9999.ebuild

index 5bd36ebec4a9d8ce849028152829b60c7b68f3c2..6cb7be71717c8bfbfd7c93d432c536142e6eba20 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=6
 
-inherit autotools eutils user linux-info systemd readme.gentoo-r1 bash-completion-r1
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools bash-completion-r1 eutils linux-info python-any-r1 readme.gentoo-r1 systemd user
 
 if [[ ${PV} = *9999* ]]; then
        inherit git-r3
@@ -115,6 +117,7 @@ RDEPEND="
        zfs? ( sys-fs/zfs )"
 
 DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
        app-text/xhtml1
        dev-lang/perl
        dev-libs/libxslt
index d6bc4279be498ad5249a2a0c7b7e0dd6e5bb6f5c..9dbad91d1f527660e75dbedcdf46b707c75f31b4 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=6
 
-inherit autotools eutils user linux-info systemd readme.gentoo-r1 bash-completion-r1
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools bash-completion-r1 eutils linux-info python-any-r1 readme.gentoo-r1 systemd user
 
 if [[ ${PV} = *9999* ]]; then
        inherit git-r3
@@ -115,6 +117,7 @@ RDEPEND="
        zfs? ( sys-fs/zfs )"
 
 DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
        app-text/xhtml1
        dev-lang/perl
        dev-libs/libxslt
index b98d98cfe371a05c3efd0521e682aac3e50efb12..f43499d923d1515d3b2948ecced45a82cbae27d3 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=6
 
-inherit autotools eutils user linux-info systemd readme.gentoo-r1 bash-completion-r1
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools bash-completion-r1 eutils linux-info python-any-r1 readme.gentoo-r1 systemd user
 
 if [[ ${PV} = *9999* ]]; then
        inherit git-r3
@@ -115,6 +117,7 @@ RDEPEND="
        zfs? ( sys-fs/zfs )"
 
 DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
        app-text/xhtml1
        dev-lang/perl
        dev-libs/libxslt
index 637c2875d6f0cbaf06deb8c1eea046a1a0105299..59de793cf86c6e03e6e74362a05bdf7fb963b52c 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=6
 
-inherit autotools eutils user linux-info systemd readme.gentoo-r1 bash-completion-r1
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools bash-completion-r1 eutils linux-info python-any-r1 readme.gentoo-r1 systemd user
 
 if [[ ${PV} = *9999* ]]; then
        inherit git-r3
@@ -115,6 +117,7 @@ RDEPEND="
        zfs? ( sys-fs/zfs )"
 
 DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
        app-text/xhtml1
        dev-lang/perl
        dev-libs/libxslt
index 3743f3a0b723240287d45eccdc02bd983f912413..72b1fb7e4bbd777df954848fdd69948835477b78 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=6
 
-inherit autotools eutils user linux-info systemd readme.gentoo-r1 bash-completion-r1
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools bash-completion-r1 eutils linux-info python-any-r1 readme.gentoo-r1 systemd user
 
 if [[ ${PV} = *9999* ]]; then
        inherit git-r3
@@ -115,6 +117,7 @@ RDEPEND="
        zfs? ( sys-fs/zfs )"
 
 DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
        app-text/xhtml1
        dev-lang/perl
        dev-libs/libxslt