dev-python/tzlocal: Bump to 2.1
authorMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 07:13:26 +0000 (09:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 09:02:56 +0000 (11:02 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/tzlocal/Manifest
dev-python/tzlocal/tzlocal-2.1.ebuild [new file with mode: 0644]

index 959b0d8e0798c640a64ec1c14e33be4c23bfd4ed..02e8cf911b5bcda04d893c9835d182a78f8308ec 100644 (file)
@@ -1 +1,2 @@
 DIST tzlocal-2.0.0.gh.tar.gz 18223 BLAKE2B 46c3132c60140ebe93a7bc0848f97d7ee7481f29544ba93d11bd6de3a6ff2d17c9e6643a844c2dc6236ef26baebec070bc60e829a95283b7c037624bdb1bda7f SHA512 b758f6ed9677e9aca3909a65f64c45ed21e8301d20ddd620be58312661c9e2a2305bed90e8b86afeae92e6be9e38a35385c8b76ccd7cb12b027c341585d7a6a6
+DIST tzlocal-2.1.gh.tar.gz 18463 BLAKE2B 73e886cfb6d13bebc1a15a222da60f368a15dc5a097acac74990b1d76bdaa229be8f12ff735d1828ccd78c4c8d06eb5bc0a07da695d70251af1e67e4fb71037e SHA512 2679cebdc2692d9e0e1c9b714994ad881896f53e75ef407229a67c9fee9d27617638a2919865cb67e21e2bbd6e3bc13f2568343037e06603236f25a96aa6863d
diff --git a/dev-python/tzlocal/tzlocal-2.1.ebuild b/dev-python/tzlocal/tzlocal-2.1.ebuild
new file mode 100644 (file)
index 0000000..fcd01ca
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="https://github.com/regebro/tzlocal"
+SRC_URI="https://github.com/regebro/tzlocal/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py