Version bump to 0.9.7. Removed 0.9.6.
authorJulien Allanos <dju@gentoo.org>
Mon, 8 Jan 2007 14:17:25 +0000 (14:17 +0000)
committerJulien Allanos <dju@gentoo.org>
Mon, 8 Jan 2007 14:17:25 +0000 (14:17 +0000)
Package-Manager: portage-2.1.1-r2

app-text/silvercity/ChangeLog
app-text/silvercity/files/digest-silvercity-0.9.6-r1
app-text/silvercity/files/digest-silvercity-0.9.7 [new file with mode: 0644]
app-text/silvercity/silvercity-0.9.7.ebuild [new file with mode: 0644]

index 23ecdb15a0685abcc301b0333778f01bd03dc620..b58c7da006854100cf2e8ceeff9e4fee4a458924 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-text/silvercity
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/ChangeLog,v 1.15 2006/06/26 03:05:06 the_paya Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/ChangeLog,v 1.16 2007/01/08 14:17:25 dju Exp $
+
+*silvercity-0.9.7 (08 Jan 2007)
+
+  08 Jan 2007; Julien Allanos <dju@gentoo.org> -silvercity-0.9.6.ebuild,
+  +silvercity-0.9.7.ebuild:
+  Version bump to 0.9.7. Removed 0.9.6.
 
   26 Jun 2006; Javier Villavicencio <the_paya@gentoo.org>
   silvercity-0.9.6-r1.ebuild:
index fe3b88eb94c35b320f2308d9e0b771bc986ea56c..5688e9fadd4a8654961af87c953175124fef38e1 100644 (file)
@@ -1 +1,3 @@
 MD5 65f2fba68f25997d46e234e1d40af304 SilverCity-0.9.6.tar.gz 267620
+RMD160 c26d69cc4a9dba34c347ffacb96f29be98803a49 SilverCity-0.9.6.tar.gz 267620
+SHA256 545f30a59e03d20d4d9a6d5f06050b1e14248d5685c7145a08cbeec11f10668b SilverCity-0.9.6.tar.gz 267620
diff --git a/app-text/silvercity/files/digest-silvercity-0.9.7 b/app-text/silvercity/files/digest-silvercity-0.9.7
new file mode 100644 (file)
index 0000000..ae451ed
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4ae4f9691798385dbde3df9cbb228e8c SilverCity-0.9.7.tar.gz 278396
+RMD160 1eb73b8af32cf3d89838950f1a659391040177bb SilverCity-0.9.7.tar.gz 278396
+SHA256 5b226e71d75c0afc4434c6fbfb44214e8728fd69703045b2134802f71ef049bd SilverCity-0.9.7.tar.gz 278396
diff --git a/app-text/silvercity/silvercity-0.9.7.ebuild b/app-text/silvercity/silvercity-0.9.7.ebuild
new file mode 100644 (file)
index 0000000..6257c08
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/silvercity-0.9.7.ebuild,v 1.1 2007/01/08 14:17:25 dju Exp $
+
+inherit distutils eutils python
+
+DESCRIPTION="A lexical analyser for many languages."
+HOMEPAGE="http://silvercity.sourceforge.net/"
+
+MY_P=${P/silvercity/SilverCity}
+SRC_URI="mirror://sourceforge/silvercity/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+
+src_install() {
+       distutils_src_install
+
+       # remove useless documentation
+       rm ${D}/usr/share/doc/${P}/PKG-INFO.gz
+
+       # fix permissions
+       python_version
+       chmod 644 ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/SilverCity/default.css
+
+       # fix CR/LF issue
+       find ${D}/usr/bin -iname "*.py" -exec sed -e 's/\r$//' -i \{\} \;
+
+       # fix path
+       dosed -i 's|#!/usr/home/sweetapp/bin/python|#!/usr/bin/env python|' \
+               /usr/bin/cgi-styler-form.py || die "dosed failed"
+}