www-servers/nginx-unit: add PHP 7.3 support
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 12:02:23 +0000 (14:02 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 14:07:46 +0000 (16:07 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-servers/nginx-unit/metadata.xml
www-servers/nginx-unit/nginx-unit-1.8.0.ebuild

index c8f76efa6ee7e05abec154ee25229d2c2e3e5b7f..ae56567e450aaf17c150ea34439232fb2f2c5ee1 100644 (file)
@@ -20,6 +20,7 @@
                <flag name="php5-6">Support for PHP 5.6</flag>
                <flag name="php7-1">Support for PHP 7.1</flag>
                <flag name="php7-2">Support for PHP 7.2</flag>
+               <flag name="php7-3">Support for PHP 7.3</flag>
        </use>
        <upstream>
                <remote-id type="github">nginx/unit</remote-id>
index 059d684520c4fb7419d3efac7e573349caec0074..3f90bad6f3618b93cccde987267e489cf25e7c81 100644 (file)
@@ -16,7 +16,7 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64"
 MY_USE="perl python ruby"
-MY_USE_PHP="php5-6 php7-1 php7-2"
+MY_USE_PHP="php5-6 php7-1 php7-2 php7-3"
 IUSE="${MY_USE} ${MY_USE_PHP}"
 REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -24,6 +24,7 @@ DEPEND="perl? ( dev-lang/perl:= )
        php5-6? ( dev-lang/php:5.6[embed] )
        php7-1? ( dev-lang/php:7.1[embed] )
        php7-2? ( dev-lang/php:7.2[embed] )
+       php7-3? ( dev-lang/php:7.3[embed] )
        python? ( ${PYTHON_DEPS} )
        ruby? ( dev-lang/ruby:= )"
 RDEPEND="${DEPEND}"