media-radio/xwxapt: Version bump to 3.4.2
authorDavid Seifert <soap@gentoo.org>
Sun, 26 Jan 2020 19:26:20 +0000 (20:26 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 26 Jan 2020 19:26:20 +0000 (20:26 +0100)
Bug: https://bugs.gentoo.org/688240
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-radio/xwxapt/Manifest
media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch [new file with mode: 0644]
media-radio/xwxapt/xwxapt-3.4.2.ebuild [new file with mode: 0644]

index 5ec99d04154b86a4bdf793cf26ff0c89f02ce69e..d6300c8805a262769301f561fd313df7ccaf94a4 100644 (file)
@@ -1,3 +1,4 @@
 DIST xwxapt-3.1.tar.bz2 258794 BLAKE2B 9a78f66a03095da209575096206e440149f329cce7be0e887704da9ef95c593e07c20107703744cfeae801e1afda94e42e312f3be788af6455d44b65c15bccb5 SHA512 68e332ddd50567181d0d8e36d1466adf7baab85670d94a92cbda478c7e61bc1bac547062b8c4ec34cbf2e832919ad76002423360c7c804525a1436ce7acb7ba9
 DIST xwxapt-3.2.tar.bz2 258901 BLAKE2B 4e82c8c21d43f9407c38699b275c690cce80555e5a738b0d22f20e32cf6586f078ba84563c4b92ebdfcc8714b24128e3f142b432e38b62cdb619976234b024fc SHA512 46adcbabaf46d0a91b5284d8171d94777846dabce62cdf36df785d9e6f94fa3df987e3b7cce636d96aed6b3cffb9b5e295dc4d46b7bc3bd209acf896c8c45858
 DIST xwxapt-3.3.tar.bz2 260010 BLAKE2B b26c8a6a05c879f1aa6f3a844f72383fdce1ce3f6efeb36305723fb3aba7f01f05cd4fd244f574e2cd8b759b499f95a5aa54db244ebefc8fb3d91d8179ce0ea5 SHA512 ea9ecc8bc5948005a09ff15e9909387980a873e9770f28efbd828a8475a0161329bd4b00e4dde9c7c50e9e4ffbfd288e25ad09224bec66250acf8eeeba23ced6
+DIST xwxapt-3.4.2.tar.bz2 262059 BLAKE2B 5e5642523e434dee6d2a35dc1be5bead3449afddb285e367cd99c7d2de14f2b1d7181bd6bc7d91a652faaa38aac3ce1b7d51d80ece665b230667674d9cb52779 SHA512 15969db9869699b09e2ddd1f800bff4956dcdedf91c5070d6747d3fa7ec22f78460adc8533917523821712b4da9f75350a8780df45bfe8741ad88d694dda6210
diff --git a/media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch b/media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch
new file mode 100644 (file)
index 0000000..7f1592e
--- /dev/null
@@ -0,0 +1,43 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,17 +35,16 @@
+ AC_CHECK_LIB([gmodule-2.0], [g_module_open])
+ # Internationalization tools
++AM_GNU_GETTEXT([external])
+ AM_GNU_GETTEXT_VERSION([0.19.8])
+ GETTEXT_PACKAGE=xwxapt
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["$GETTEXT_PACKAGE"], [Gettext package.])
+-AM_GNU_GETTEXT
+ PROGRAMNAME_LOCALEDIR=[${datadir}/locale]
+ AC_SUBST(PROGRAMNAME_LOCALEDIR)
+ # Add the languages which your application supports here.
+ ALL_LINGUAS=""
+-AM_GNU_GETTEXT
+ # Checks for header files.
+ AC_CHECK_HEADERS([libintl.h stdlib.h string.h unistd.h])
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -48,18 +48,5 @@
+       if test -d files/; then \
+         cp files/$(PACKAGE).desktop $(DESTDIR)/usr/share/applications/; \
+         cp files/$(PACKAGE).png $(DESTDIR)/usr/share/pixmaps/; \
+-      fi; \
+-      if !(test -d $(DESTDIR)/usr/share/doc/$(PACKAGE)); then \
+-        mkdir $(DESTDIR)/usr/share/doc/$(PACKAGE)/; \
+-      fi; \
+-      if test -d doc/; then \
+-        cp -r doc/* $(DESTDIR)/usr/share/doc/$(PACKAGE)/; \
+-        cp -r doc/$(PACKAGE).1.gz $(DESTDIR)/usr/share/man/man1/; \
+-      fi; \
+-      if !(test -d /home/`logname`/$(PACKAGE)); then \
+-        cp -r $(PACKAGE) /home/`logname`/; \
+-      else \
+-        cp $(PACKAGE)/$(PACKAGE).glade /home/`logname`/$(PACKAGE); \
+-      fi; \
+-      chown -R `logname`:`logname` /home/`logname`/$(PACKAGE);
++      fi; 
diff --git a/media-radio/xwxapt/xwxapt-3.4.2.ebuild b/media-radio/xwxapt/xwxapt-3.4.2.ebuild
new file mode 100644 (file)
index 0000000..3b6927d
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
+HOMEPAGE="http://www.qsl.net/5b4az/pages/apt.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/apt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-libs/glib:2
+       media-libs/alsa-lib
+       net-wireless/rtl-sdr
+       x11-libs/gtk+:3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-fix-autotools.patch )
+HTML_DOCS=( doc/xwxapt.html )
+
+src_prepare() {
+       default
+
+       # create missing mkinstalldir and prepare package
+       eautoreconf
+}
+
+src_install() {
+       default
+
+       insinto /usr/share/${PN}
+       doins xwxapt/xwxaptrc
+       doins xwxapt/xwxapt.glade
+       dodir /usr/share/${PN}/images /usr/share/${PN}/records
+}
+
+pkg_postinst() {
+       einfo "You must copy the /usr/share/xwxapt directory into your home directory"
+       einfo "and configure the contained xwxaptrc file before starting the program"
+
+       ewarn
+       ewarn "If you just upgraded from <=xwxapt-3 do not miss to check"
+       ewarn "for changes there"
+}