www-client/qutebrowser: Bump 9999 dependencies
authorGuillaume Seren <guillaumeseren@gmail.com>
Thu, 7 May 2020 20:18:31 +0000 (22:18 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 12 May 2020 13:57:06 +0000 (16:57 +0300)
Closes: https://bugs.gentoo.org/721544
Closes: https://bugs.gentoo.org/718120
Bug: https://bugs.gentoo.org/721564
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-client/qutebrowser/qutebrowser-9999.ebuild

index 759f00f438679e097dd678e53c1995d43798e08d..d5b853c5def090bd170fee643d7d68342d065ec0 100644 (file)
@@ -3,7 +3,8 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
 
 inherit desktop distutils-r1 eutils xdg-utils
 
@@ -22,38 +23,31 @@ LICENSE="GPL-3"
 SLOT="0"
 IUSE="scripts test"
 
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="
-       app-text/asciidoc
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+BDEPEND="
+       app-text/asciidoc"
 RDEPEND="
        >=dev-python/attrs-19.3.0[${PYTHON_USEDEP}]
        >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
        >=dev-python/cssutils-1.0.2[${PYTHON_USEDEP}]
-       >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
-       >=dev-python/pygments-2.5.2[${PYTHON_USEDEP}]
+       >=dev-python/jinja-2.11.2[${PYTHON_USEDEP}]
+       >=dev-python/markupsafe-1.1.1[${PYTHON_USEDEP}]
+       >=dev-python/pygments-2.6.1[${PYTHON_USEDEP}]
        >=dev-python/pypeg2-2.15.2[${PYTHON_USEDEP}]
        >=dev-python/PyQt5-5.14.1[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
        >=dev-python/PyQtWebEngine-5.14.0[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-5.3[${PYTHON_USEDEP},libyaml]
+       >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP},libyaml]
 "
 
+distutils_enable_tests setup.py
+
 # Tests restricted as the deplist (misc/requirements/requirements-tests.txt)
 # isn't complete and X11 is required in order to start up qutebrowser.
 RESTRICT="test"
 
 python_compile_all() {
-       if [[ ${PV} == "9999" ]]; then
-               "${EPYTHON}" scripts/asciidoc2html.py || die "Failed generating docs"
-       fi
-
        a2x -f manpage doc/${PN}.1.asciidoc || die "Failed generating man page"
 }
 
-python_test() {
-       py.test tests || die "Tests failed with ${EPYTHON}"
-}
-
 python_install_all() {
        doman doc/${PN}.1
        domenu misc/org.${PN}.${PN}.desktop