app-admin/vault: inherit go-build for GOPATH setting with get_golibdir_gopath
authorZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 05:11:46 +0000 (22:11 -0700)
committerZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 05:35:15 +0000 (22:35 -0700)
Package-Manager: portage-2.2.20

app-admin/vault/vault-0.1.2-r1.ebuild
app-admin/vault/vault-0.1.2.ebuild
app-admin/vault/vault-9999.ebuild

index 770c1bb3ae44fd13b4cf7c0267f9468e493c1338..f2adc6d07eb0a81e7dce2b852fee62ec0394062c 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit fcaps systemd user
+inherit fcaps golang-build systemd user
 
 KEYWORDS="~amd64"
 DESCRIPTION="A tool for managing secrets"
@@ -13,9 +13,9 @@ GO_PN="github.com/hashicorp/${PN}"
 LICENSE="MPL-2.0"
 SLOT="0"
 IUSE=""
+RESTRICT="test"
 
-DEPEND=">=dev-lang/go-1.4:=
-       dev-go/go-oauth2:="
+DEPEND="dev-go/go-oauth2:="
 RDEPEND=""
 
 SRC_URI="https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
@@ -45,7 +45,7 @@ src_unpack() {
        cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
        rm -rf "${GOROOT}/src/${GO_PN}" || die
 
-       export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace
+       export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace:$(get_golibdir_gopath)
 
        while read -r -d '' x; do
                rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die
index fad7f2eaf09f9193ea07f7e18d4e62320af5bb37..452afb6f7e1ef57451d05fe74cbef209f4f4c6b8 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit fcaps systemd user
+inherit fcaps golang-build systemd user
 
 KEYWORDS="~amd64"
 DESCRIPTION="A tool for managing secrets"
@@ -13,9 +13,9 @@ GO_PN="github.com/hashicorp/${PN}"
 LICENSE="MPL-2.0"
 SLOT="0"
 IUSE=""
+RESTRICT="test"
 
-DEPEND=">=dev-lang/go-1.4
-       dev-go/go-oauth2"
+DEPEND="dev-go/go-oauth2"
 RDEPEND=""
 
 SRC_URI="https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
@@ -45,7 +45,7 @@ src_unpack() {
        cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
        rm -rf "${GOROOT}/src/${GO_PN}" || die
 
-       export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace
+       export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace:$(get_golibdir_gopath)
 
        while read -r -d '' x; do
                rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die
index f315b8c6068929b49ffaa8c503fb7b3e9bfd9082..41d51d37941f4a28850054de782d21ea9d029911 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit fcaps git-r3 systemd user
+inherit fcaps git-r3 golang-build systemd user
 
 KEYWORDS=""
 DESCRIPTION="A tool for managing secrets"
@@ -14,9 +14,9 @@ EGIT_REPO_URI="git://${GO_PN}.git"
 LICENSE="MPL-2.0"
 SLOT="0"
 IUSE=""
+RESTRICT="test"
 
-DEPEND=">=dev-lang/go-1.4:=
-       dev-go/go-oauth2:="
+DEPEND="dev-go/go-oauth2:="
 RDEPEND=""
 
 SRC_URI=""
@@ -43,7 +43,7 @@ src_unpack() {
        cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
        rm -rf "${GOROOT}/src/${GO_PN}" || die
 
-       export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace
+       export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace:$(get_golibdir_gopath)
 
        while read -r -d '' x; do
                rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die