net-dialup/rp-l2tp: Fix parallel build (#567744 by Felix Janda)
authorPacho Ramos <pacho@gentoo.org>
Mon, 2 Apr 2018 10:02:16 +0000 (12:02 +0200)
committerPacho Ramos <pacho@gentoo.org>
Mon, 2 Apr 2018 10:02:16 +0000 (12:02 +0200)
Package-Manager: Portage-2.3.27, Repoman-2.3.9

net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch
net-dialup/rp-l2tp/files/rp-l2tp-0.4-parallel-build.patch [new file with mode: 0644]
net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild

index 7bb534b679404cf7e064fa05230cadf16ca186b8..6ba8630e43d60b372f107af6b25f616f753ec26b 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile.in.orig   2014-06-24 15:20:47.028342728 +0400
-+++ Makefile.in        2014-06-24 15:21:07.468320934 +0400
+--- a/Makefile.in.orig 2014-06-24 15:20:47.028342728 +0400
++++ b/Makefile.in      2014-06-24 15:21:07.468320934 +0400
 @@ -39,8 +39,8 @@
  
  libl2tp.a: $(OBJS)
@@ -11,8 +11,8 @@
  
  l2tpd: libl2tp.a libevent/libevent.a
        $(MAKE) -C handlers
---- libevent/Makefile.in.orig  2002-09-30 23:45:00.000000000 +0400
-+++ libevent/Makefile.in       2014-06-24 15:24:31.535105268 +0400
+--- a/libevent/Makefile.in.orig        2002-09-30 23:45:00.000000000 +0400
++++ b/libevent/Makefile.in     2014-06-24 15:24:31.535105268 +0400
 @@ -18,20 +18,20 @@
  
  libevent.a: $(OBJS)
@@ -39,8 +39,8 @@
  
  clean: FORCE
        rm -f *.a *.o *~
---- handlers/Makefile.in.orig  2014-06-24 15:31:35.186667624 +0400
-+++ handlers/Makefile.in       2014-06-24 15:32:26.659615281 +0400
+--- a/handlers/Makefile.in.orig        2014-06-24 15:31:35.186667624 +0400
++++ b/handlers/Makefile.in     2014-06-24 15:32:26.659615281 +0400
 @@ -20,19 +20,19 @@
  all: $(HANDLERS) l2tp-control
  
diff --git a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-parallel-build.patch b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-parallel-build.patch
new file mode 100644 (file)
index 0000000..cfbb096
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/Makefile.in~     2018-04-02 11:58:30.000000000 +0200
++++ b/Makefile.in      2018-04-02 12:00:15.173470572 +0200
+@@ -42,8 +42,7 @@
+       $(AR) -rc $@ $^
+       @RANLIB@ $@ || true
+-l2tpd: libl2tp.a libevent/libevent.a
+-      $(MAKE) -C handlers
++l2tpd: libl2tp.a libevent/libevent.a handlers
+       @CC@ $(LDFLAGS) -o l2tpd -rdynamic $(OBJS) $(EXTRA_LIBS)
+ libevent/libevent.a:
index cfe036f1c5881d943e75c7127c503d4fd4ddbf13..7d468429c0acfec62c936764e38fb55a8ba14ecb 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-inherit eutils toolchain-funcs
+EAPI=6
+inherit toolchain-funcs
 
 DESCRIPTION="User-space implementation of L2TP for Linux and other UNIX systems"
 HOMEPAGE="https://sourceforge.net/projects/rp-l2tp/"
@@ -13,19 +12,22 @@ LICENSE="GPL-2"
 KEYWORDS="amd64 ~ppc x86"
 SLOT="0"
 
+PATCHES=(
+       "${FILESDIR}/${P}-gentoo.patch"
+       "${FILESDIR}/${P}-flags.patch"
+       "${FILESDIR}/${P}-build.patch"
+       "${FILESDIR}/${P}-parallel-build.patch"
+)
+
 src_prepare() {
        tc-export AR CC RANLIB
-       epatch \
-               "${FILESDIR}/${P}-gentoo.patch" \
-               "${FILESDIR}/${P}-flags.patch" \
-               "${FILESDIR}/${P}-build.patch"
-       epatch_user
+       default
 }
 
 src_install() {
        emake RPM_INSTALL_ROOT="${D}" install
 
-       dodoc README
+       einstalldocs
        newdoc l2tp.conf rp-l2tpd.conf
        docinto libevent
        dodoc libevent/Doc/*