app-crypt/certbot: 0.36.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Jul 2019 18:52:55 +0000 (13:52 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Jul 2019 18:58:58 +0000 (13:58 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/certbot/Manifest
app-crypt/certbot/certbot-0.36.0.ebuild [new file with mode: 0644]
app-crypt/certbot/certbot-9999.ebuild

index cc587dde9d25195faad0c179f4e1dcbf3678fdc7..8e39bf083ccc73158dc0d5c44e83b1492b8f8495 100644 (file)
@@ -1,2 +1,3 @@
 DIST certbot-0.34.2.tar.gz 1347778 BLAKE2B 57195e3a7a3481c4c1fa184035b73b8b5e06a33f37b317d895381ec6c4b57852a475a3b76593b8fee9922f731512ed0d0423afa26b5c04138d24781df9da42f0 SHA512 63923b1d433f4c714318e848335e696e2412c574cc16f4fb1631caeebdce5a7f599985cf450e96dceb87a958c8f09a003e1d2f24eac1bdc183c7a5c43bb362de
 DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
+DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
diff --git a/app-crypt/certbot/certbot-0.36.0.ebuild b/app-crypt/certbot/certbot-0.36.0.ebuild
new file mode 100644 (file)
index 0000000..c556797
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       ${CDEPEND}
+       >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+       >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+       dev-python/configobj[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
+       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+       dev-python/pyrfc3339[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       dev-python/zope-component[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="
+       ${CDEPEND}
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       # acme is not installed, removing it here is fine, the dir just confuses tests
+       rm -R acme
+       pytest -vv ${PN} || die
+}
index d1e115014c9a3153a05de5bb6510be148686ae2e..c5567979351186e4bbf095255448f7b5e33c57e5 100644 (file)
@@ -27,7 +27,7 @@ RDEPEND="
        >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
        >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
        dev-python/configobj[${PYTHON_USEDEP}]
-       >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
        >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
        dev-python/mock[${PYTHON_USEDEP}]
        >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]