dev-python/ruamel-yaml-clib: new package, sort of
authorMarek Szuba <marecki@gentoo.org>
Fri, 24 Apr 2020 14:52:37 +0000 (15:52 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 24 Apr 2020 14:53:39 +0000 (15:53 +0100)
This used to be part of dev-python/ruamel-yaml prior to its version
0.16 (which is why why have already got ~arm64 and ~x86 in KEYWORDS),
now however it is a (theoretically optional) separate package.

Assigning myself as maintainer for the time being, that said I'll be
happy to transfer it to Andrey and Foster once they have reported back
on the subject of ruamel.yaml version bump.

Bug: https://bugs.gentoo.org/711070
Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-python/ruamel-yaml-clib/Manifest [new file with mode: 0644]
dev-python/ruamel-yaml-clib/metadata.xml [new file with mode: 0644]
dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/ruamel-yaml-clib/Manifest b/dev-python/ruamel-yaml-clib/Manifest
new file mode 100644 (file)
index 0000000..020eb06
--- /dev/null
@@ -0,0 +1 @@
+DIST ruamel.yaml.clib-0.2.0.tar.gz 178084 BLAKE2B a4d23e5c931a0c720edb80818ca11bfcc1638f28ec910878f53720139bd8fbd034de6db73154c0e758ceb6c5233c10a2bf7d779f8e7f4a134c8b07cc33382a1b SHA512 7d716e27963b97a1735ba7ff0e581f7ecdfa62725cc42def59ad0ccdf9e23a9f7dfbc3cac298bb3e29362535036b07ba0f523452d6f73248be53c69796637e34
diff --git a/dev-python/ruamel-yaml-clib/metadata.xml b/dev-python/ruamel-yaml-clib/metadata.xml
new file mode 100644 (file)
index 0000000..96c439a
--- /dev/null
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>marecki@gentoo.org</email>
+               <name>Marek Szuba</name>
+       </maintainer>
+       <longdescription>
+               This package was split of from ruamel.yaml, so that ruamel.yaml can be
+               built as a universal wheel. Apart from the C code seldom changing, and
+               taking a long time to compile for all platforms, this allows
+               installation of the .so on Linux systems under /usr/lib64/pythonX.Y
+               (without a .pth file or a ruamel directory) and the Python code for
+               ruamel.yaml under /usr/lib/pythonX.Y.
+       </longdescription>
+       <upstream>
+               <remote-id type="pypi">ruamel.yaml.clib</remote-id>
+               <remote-id type="sourceforge">ruamel-yaml-clib</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..ef3e670
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="C-based reader/scanner and emitter for dev-python/ruamel-yaml"
+HOMEPAGE="https://pypi.org/project/ruamel.yaml.clib/ https://sourceforge.net/p/ruamel-yaml-clib"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="!<dev-python/ruamel-yaml-0.16.0"
+
+S="${WORKDIR}"/${MY_P}
+
+python_install() {
+       distutils-r1_python_install --single-version-externally-managed
+}