media-plugins/vdr-epgsearch: fix QA issues, #694644
authorMartin Dummer <martin.dummer@gmx.net>
Mon, 14 Oct 2019 21:26:59 +0000 (23:26 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 17 Oct 2019 04:51:17 +0000 (07:51 +0300)
remove duplicate identical patch files
update ebuild headers
add QA_FLAGS_IGNORED hint

Closes: https://bugs.gentoo.org/694644
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Martin Dummer <martin.dummer@gmx.net>
Closes: https://github.com/gentoo/gentoo/pull/13304
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.x.makefile.patch [moved from media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.1_beta5_makefile.diff with 100% similarity]
media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.2.0_makefile.diff [deleted file]
media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.1_p20141227-r1.ebuild
media-plugins/vdr-epgsearch/vdr-epgsearch-2.2.0.ebuild

diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.2.0_makefile.diff b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.2.0_makefile.diff
deleted file mode 100644 (file)
index 25e27e9..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naur vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile
---- vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile        2015-02-21 21:01:08.926052710 +0100
-+++ vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile     2015-02-21 21:03:42.768052710 +0100
-@@ -255,9 +255,9 @@
- docs:
-       ./docsrc2man.sh
-       ./docsrc2html.sh
--      ln -sf ./doc/en/epgsearch.4.txt MANUAL
--      ln -sf ./doc/en/epgsearch.1.txt README
--      ln -sf ./doc/de/epgsearch.1.txt README.DE
-+#     ln -sf ./doc/en/epgsearch.4.txt MANUAL
-+#     ln -sf ./doc/en/epgsearch.1.txt README
-+#     ln -sf ./doc/de/epgsearch.1.txt README.DE
- install-$(PLUGIN): libvdr-$(PLUGIN).so
-       install -D libvdr-$(PLUGIN).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
-@@ -272,7 +272,7 @@
-       install -D libvdr-$(PLUGIN4).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN4).so.$(APIVERSION)
- install-conf:
--      mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)/conf.d
-+      mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)
-       cp -n conf/* $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)
- install-doc:
index ddd0e54173a16b9375b4950341bea397f4108c12..c79abd511d1d176a34d480a034835d43e84a4a11 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -36,6 +36,7 @@ DEPEND="media-video/vdr
        pcre? ( dev-libs/libpcre )
        tre? ( dev-libs/tre )"
 RDEPEND="${DEPEND}"
+QA_FLAGS_IGNORED="usr/lib/vdr/plugins/libvdr-.* usr/lib64/vdr/plugins/libvdr-.* usr/bin/createcats"
 
 src_prepare() {
        # make detection in vdr-plugin-2.eclass for new Makefile handling happy
@@ -45,7 +46,7 @@ src_prepare() {
        rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po || die "cannot remove .po files"
 
        local PATCHES=(
-               "${FILESDIR}/vdr-epgsearch-1.0.1_beta5_makefile.diff"
+               "${FILESDIR}/vdr-epgsearch-1.x.makefile.patch"
                "${FILESDIR}/fix-manpage-generation.diff"
                )
 
index bfc710beb8f32dd3f79caa8316c04a64aa478020..036df79eeb1ecb022d7be06dd958caf80375d39b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -18,6 +18,7 @@ DEPEND="=media-video/vdr-2.2*
        pcre? ( dev-libs/libpcre )
        tre? ( dev-libs/tre )"
 RDEPEND="${DEPEND}"
+QA_FLAGS_IGNORED="usr/lib/vdr/plugins/libvdr-.* usr/lib64/vdr/plugins/libvdr-.* usr/bin/createcats"
 
 REQUIRED_USE="?? ( pcre tre )"
 
@@ -30,7 +31,7 @@ src_prepare() {
        # remove untranslated .po files
        rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
 
-       eapply "${FILESDIR}/${P}_makefile.diff"
+       eapply "${FILESDIR}/vdr-epgsearch-1.x.makefile.patch"
 
        use conflictcheckonly || sed -e "s:install-\$(PLUGIN3)::" -i Makefile
        use epgsearchonly || sed -e "s:install-\$(PLUGIN2)::" -i Makefile