sys-apps/kexec-tools: update the live ebuild
authorSergey Alirzaev <zl29ah@gmail.com>
Wed, 18 Oct 2017 22:36:00 +0000 (01:36 +0300)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 19 Oct 2017 09:15:39 +0000 (11:15 +0200)
git -> https and make it build
Closes: https://github.com/gentoo/gentoo/pull/5979

sys-apps/kexec-tools/kexec-tools-9999.ebuild

index f3f01574c051c3393e1c6a68294b2250b95abd0d..784f7a48e98b512210493b82205b2c752ffd91e6 100644 (file)
@@ -4,9 +4,8 @@
 EAPI=6
 
 if [[ ${PV} == "9999" ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
-       AUTOTOOLS_AUTORECONF=true
+       inherit git-r3 autotools
+       EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
 else
        SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
        KEYWORDS="~amd64 ~arm64 ~x86"
@@ -42,7 +41,11 @@ pkg_setup() {
 
 src_prepare() {
        default
-       elibtoolize
+       if [[ ${PV} == "9999" ]] ; then
+               eautoreconf
+       else
+               elibtoolize
+       fi
 }
 
 src_configure() {