dev-python/twisted: Remove +x from files/trial
authorMichał Górny <mgorny@gentoo.org>
Wed, 18 Sep 2019 16:17:04 +0000 (18:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 18 Sep 2019 16:23:23 +0000 (18:23 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/twisted/files/trial [changed mode: 0755->0644]
dev-python/twisted/twisted-16.6.0-r3.ebuild
dev-python/twisted/twisted-17.1.0-r2.ebuild
dev-python/twisted/twisted-17.9.0.ebuild
dev-python/twisted/twisted-18.4.0.ebuild
dev-python/twisted/twisted-18.7.0.ebuild

old mode 100755 (executable)
new mode 100644 (file)
index cc2d554f4023286b4425e7a2b7f8454d3d786ee2..61c95aa34aad096e22deed0aff6dcef77d1631dd 100644 (file)
@@ -112,7 +112,8 @@ python_test() {
        # workaround for the eclass not installing the entry points
        # in the test environment.  copy the old 16.3.2 start script
        # to run the tests with
-       cp "${FILESDIR}"/trial "${TEST_DIR}"
+       cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+       chmod +x "${TEST_DIR}"/trial || die
 
        pushd "${TEST_DIR}" > /dev/null || die
 
index 7b72031402e44d24a0e0cd09b32555ce5d935b46..2c5297195b289b179127eab83eb7ac70ce6c2b41 100644 (file)
@@ -113,7 +113,8 @@ python_test() {
        # workaround for the eclass not installing the entry points
        # in the test environment.  copy the old 16.3.2 start script
        # to run the tests with
-       cp "${FILESDIR}"/trial "${TEST_DIR}"
+       cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+       chmod +x "${TEST_DIR}"/trial || die
 
        pushd "${TEST_DIR}" > /dev/null || die
 
index d9ab3a98e0b0d0fe3c4af516b3a75b377eee80ad..2af9dc59009986133d3f236cddac34cc08995134 100644 (file)
@@ -120,7 +120,8 @@ python_test() {
        # workaround for the eclass not installing the entry points
        # in the test environment.  copy the old 16.3.2 start script
        # to run the tests with
-       cp "${FILESDIR}"/trial "${TEST_DIR}"
+       cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+       chmod +x "${TEST_DIR}"/trial || die
 
        pushd "${TEST_DIR}" > /dev/null || die
 
index 05bc6ecafa7b4ca9b6a080e9ec2ffa33c7c23bf8..62428e4db2266ca4696382847d881299910e2ee2 100644 (file)
@@ -119,7 +119,8 @@ python_test() {
        # workaround for the eclass not installing the entry points
        # in the test environment.  copy the old 16.3.2 start script
        # to run the tests with
-       cp "${FILESDIR}"/trial "${TEST_DIR}"
+       cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+       chmod +x "${TEST_DIR}"/trial || die
 
        pushd "${TEST_DIR}" > /dev/null || die
 
index a3d79b03733a269fa3a6349270995ea594a1df2a..9b927dd62be5ea45f4c6187d050a982289a73f66 100644 (file)
@@ -121,7 +121,8 @@ python_test() {
        # workaround for the eclass not installing the entry points
        # in the test environment.  copy the old 16.3.2 start script
        # to run the tests with
-       cp "${FILESDIR}"/trial "${TEST_DIR}"
+       cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+       chmod +x "${TEST_DIR}"/trial || die
 
        pushd "${TEST_DIR}" > /dev/null || die