net-wireless/iwd: fetch ell.git using git-r3
authorMike Gilbert <floppym@gentoo.org>
Fri, 1 Nov 2019 15:15:50 +0000 (11:15 -0400)
committerBen Kohler <bkohler@gentoo.org>
Fri, 1 Nov 2019 16:22:55 +0000 (11:22 -0500)
Bug: https://bugs.gentoo.org/699042
Package-Manager: Portage-2.3.78_p4, Repoman-2.3.17_p100
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-wireless/iwd/iwd-9999.ebuild

index bcf7602ab7a9f270ba15e86b8884d9a491aff751..32c1b7fd134efb0831d9013de36efabcea1b9535 100644 (file)
@@ -5,8 +5,9 @@ EAPI=6
 inherit flag-o-matic linux-info systemd
 
 if [[ ${PV} == *9999* ]]; then
-       EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
        inherit autotools git-r3
+       IWD_EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
+       ELL_EGIT_REPO_URI="https://git.kernel.org/pub/scm/libs/ell/ell.git"
 else
        SRC_URI="https://www.kernel.org/pub/linux/network/wireless/${P}.tar.xz"
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~sparc ~x86"
@@ -101,8 +102,8 @@ pkg_pretend() {
 
 src_unpack() {
        if [[ ${PV} == *9999* ]] ; then
-               git-r3_src_unpack
-               git clone git://git.kernel.org/pub/scm/libs/ell/ell.git "${WORKDIR}"/ell
+               EGIT_REPO_URI=${IWD_EGIT_REPO_URI} git-r3_src_unpack
+               EGIT_REPO_URI=${ELL_EGIT_REPO_URI} EGIT_CHECKOUT_DIR=${S}/ell git-r3_src_unpack
        else
                default
        fi