dev-python/prompt_toolkit: bump to version 2.0.10.
authorGabriel Linder <linder.gabriel@gmail.com>
Sun, 8 Dec 2019 12:37:21 +0000 (13:37 +0100)
committerAaron Bauman <bman@gentoo.org>
Thu, 12 Dec 2019 19:31:32 +0000 (14:31 -0500)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com>
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/prompt_toolkit/Manifest
dev-python/prompt_toolkit/metadata.xml
dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild [new file with mode: 0644]

index a04359be984052b7c92807fc4062f37b71ae5f9f..606c710da9f95ed24cab8004025e2e2df17d0854 100644 (file)
@@ -1,3 +1,4 @@
 DIST prompt_toolkit-1.0.15.tar.gz 243734 BLAKE2B b27e61bb444360abe95714e2014fcacf2355da0540b21af35cc40cb0f0115d0a3b027236235a89a95c1ec1fa947bf5b88b236b737fab5de78e7bd5fc798aa764 SHA512 10981be2ed8b71d0cd9f663c4de047cec9664d9276968c6eec40dc45b388d1acf8eba07d534369254f178931079bf39b04eb2ceac06aa63a2021ebf62387b2f5
+DIST prompt_toolkit-2.0.10.tar.gz 347981 BLAKE2B b95cf000d5249da3710f9b51f72d41c3d552f1d3a35dea5493f565f0f62998d890bf2b81b3376140a4d16a19f2c5fd60eb0cb5f2f58180c176ef1543c6fc4ec2 SHA512 b91292cf43607b3a7018ca29827f0aa9bc90efc064c68faffe02ad28e4bb60f45fc2d25bbfd9a40a383a815cb08596975f08237a498f94a5c088d56d3a0a9803
 DIST prompt_toolkit-2.0.6.tar.gz 339714 BLAKE2B f969edef98d25930e4d61c1500bb9c8d731dea29e8d154e6baa2ab4045ceaf9d577d46024734a255cc15a4c13685582309e9d2fe7ae3320257f6fd1f9981ada6 SHA512 37082011ee5b8d6fd9febef95c92494ed6108b9ad8c64ac580b69c3464781a2f0dcef5b1c4d06fe309a3036932f7c622042e6b2293acf2ab6f9f2aa3c48d9322
 DIST prompt_toolkit-2.0.7.tar.gz 343267 BLAKE2B eed36fb951bcf8b0663a87eb4e77267246bbc7a6b773ed76d730c04b4dd012434fd0e71e5f558c231fd5ba1e8b3403878106bf3c60f44b7aa3e492a99a622b65 SHA512 4ea8102a50290878248ccc2119eb2b5ae50ad58f466510f8328bc172942f5417abde24393958c910ae0ab2ea4a8caff049b6e7acd8d94e9dbeb97b36c6e2191e
index 29e9faaf3f1cf3402ec8603e206445bd62a01e1d..3ff66414d0a8357f32e6ed0fed9ca0a6ca568aa8 100644 (file)
@@ -7,6 +7,6 @@
   </maintainer>
   <upstream>
     <remote-id type="pypi">prompt_toolkit</remote-id>
-    <remote-id type="github">jonathanslenders/python-prompt-toolkit</remote-id>
+    <remote-id type="github">prompt-toolkit/python-prompt-toolkit</remote-id>
   </upstream>
 </pkgmetadata>
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild
new file mode 100644 (file)
index 0000000..d119b24
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest