dev-python/spyder: version bump 4.1.1
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Thu, 19 Mar 2020 12:05:53 +0000 (13:05 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 27 Mar 2020 16:25:01 +0000 (18:25 +0200)
Bug: https://bugs.gentoo.org/714760

Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Closes: https://github.com/gentoo/gentoo/pull/15012
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/spyder/Manifest
dev-python/spyder/files/spyder-4.1.1-build.patch [moved from dev-python/spyder/files/spyder-4.0.1-build.patch with 100% similarity]
dev-python/spyder/files/spyder-4.1.1-py3-only.patch [moved from dev-python/spyder/files/spyder-4.0.1-py3-only.patch with 82% similarity]
dev-python/spyder/spyder-4.1.1.ebuild [moved from dev-python/spyder/spyder-4.0.1-r1.ebuild with 81% similarity]

index aaa6df24d22d3320f8d824b346b64d12dc773d65..fe894fbf23ad7c23ca3f8b1a558952e143988e7f 100644 (file)
@@ -1,2 +1,2 @@
-DIST spyder-4.0.1.tar.gz 10783565 BLAKE2B 5d264991b9bfc8118ef91f929269a300932cb0078b70c54613836c4337dc41214aa4ab81dacb4a535aaa6dea6b1eb591e25c7071664dc102e218373a0d7f8824 SHA512 9249a3b4a73ebe7a485d75fe2bea68bfa106c8ad0710120a6e05a43e3e2a65f9076904d1104180e925ab282b1d9da712c3509e0a5a7cfe3bd5ea8a95a1617bdd
+DIST spyder-4.1.1.tar.gz 11135335 BLAKE2B fc253ea266b368f372f2f0de30120d58c0e5c6e4cf474ccec0884c5fd3557cbd929eb17c0b9f2ee04745861499e12f54e61566507d844c9cf804bef65b3438d4 SHA512 e778dbac4c3f3462c32c9117ce6f6a8e5f2c8df5317695d76bf7a61995cac7be2e224cb751eda337b32442c9a32a7d53f8779a9288f15ad8d1a7aac9d328237c
 DIST spyder-docs-7c0b590.tar.gz 2257637 BLAKE2B 7e9528fde453631227ece3bd8c9163a0b3daadf3a83160b5475f943c49e7a559ff33dfe03531240b99571c535887ecff8459116d566dd7c739c74c4165e00060 SHA512 4d9548cc69db85ae6e93cac64e680460da6f9e76bf8b1265b31fbd4925786d29427de40bf06fd52ba807b0bb8f6c224e35b809c0e015a77013deb383e6d666f8
similarity index 82%
rename from dev-python/spyder/files/spyder-4.0.1-py3-only.patch
rename to dev-python/spyder/files/spyder-4.1.1-py3-only.patch
index df5f0c4ad1c6f4f0a18b30b2bd457c806263ac84..afdc92a1e1224823bd601228ad84ef0de0d88145 100644 (file)
@@ -1,5 +1,5 @@
 diff --git a/setup.py b/setup.py
-index a492549..b77f758 100644
+index 2d5d58b..4adc952 100644
 --- a/setup.py
 +++ b/setup.py
 @@ -31,13 +31,6 @@ import shutil
@@ -28,23 +28,22 @@ index a492549..b77f758 100644
 -            data_files = [('share/applications', ['scripts/spyder.desktop']),
 -                          ('share/icons', ['img_src/spyder.png'])]
 +        data_files = [('share/applications', ['scripts/spyder.desktop']),
-+                      ('share/pixmaps', ['img_src/spyder.png'])]
++                      ('share/icons', ['img_src/spyder.png'])]
      elif os.name == 'nt':
          data_files = [('scripts', ['img_src/spyder.ico',
                                     'img_src/spyder_reset.ico'])]
-@@ -115,10 +103,7 @@ def get_packages():
- # platforms due to a bug in pip installation process
+@@ -131,9 +119,7 @@ CMDCLASS = {'install_data': MyInstallData}
  # See spyder-ide/spyder#1158.
  SCRIPTS = ['%s_win_post_install.py' % NAME]
 -if PY3 and sys.platform.startswith('linux'):
 -    SCRIPTS.append('spyder3')
 -else:
--    SCRIPTS.append('spyder')
-+SCRIPTS.append('spyder')
++if sys.platform.startswith('linux'):
+     SCRIPTS.append('spyder')
  
- #==============================================================================
-@@ -246,8 +231,7 @@ if 'setuptools' in sys.modules:
+ if os.name == 'nt':
+@@ -269,8 +255,7 @@ if 'setuptools' in sys.modules:
  
      setup_args['entry_points'] = {
          'gui_scripts': [
similarity index 81%
rename from dev-python/spyder/spyder-4.0.1-r1.ebuild
rename to dev-python/spyder/spyder-4.1.1.ebuild
index 43bba250f2c41543f4334f049074a2c4d831cacc..440d4fa18c2253df7b545a1f881dafceb8701063 100644 (file)
@@ -28,26 +28,28 @@ RDEPEND="
        >=dev-python/cloudpickle-0.5.0[${PYTHON_USEDEP}]
        >=dev-python/diff-match-patch-20181111[${PYTHON_USEDEP}]
        dev-python/intervaltree[${PYTHON_USEDEP}]
-       ~dev-python/jedi-0.14.1[${PYTHON_USEDEP}]
+       >=dev-python/ipython-4.0[${PYTHON_USEDEP}]
+       ~dev-python/jedi-0.15.2[${PYTHON_USEDEP}]
        dev-python/keyring[${PYTHON_USEDEP}]
        >=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
        >=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
+       ~dev-python/parso-0.5.2[${PYTHON_USEDEP}]
        >=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
        >=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
-       >=dev-python/psutil-0.3[${PYTHON_USEDEP}]
+       >=dev-python/psutil-5.3[${PYTHON_USEDEP}]
        >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
        >=dev-python/pylint-0.25[${PYTHON_USEDEP}]
-       >=dev-python/python-language-server-0.31.2[${PYTHON_USEDEP}]
+       >=dev-python/python-language-server-0.31.9[${PYTHON_USEDEP}]
        <dev-python/python-language-server-0.32.0[${PYTHON_USEDEP}]
        >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
        >=dev-python/pyzmq-17.0.0[${PYTHON_USEDEP}]
-       >=dev-python/qdarkstyle-2.7[${PYTHON_USEDEP}]
+       >=dev-python/qdarkstyle-2.8[${PYTHON_USEDEP}]
        >=dev-python/qtawesome-0.5.7[${PYTHON_USEDEP}]
        >=dev-python/qtconsole-4.6.0[${PYTHON_USEDEP}]
        >=dev-python/QtPy-1.5.0[${PYTHON_USEDEP},svg,webengine]
        >=dev-python/sphinx-0.6.6[${PYTHON_USEDEP}]
-       >=dev-python/spyder-kernels-1.8.1[${PYTHON_USEDEP}]
-       <dev-python/spyder-kernels-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/spyder-kernels-1.9.0[${PYTHON_USEDEP}]
+       <dev-python/spyder-kernels-1.10.0[${PYTHON_USEDEP}]
        dev-python/watchdog[${PYTHON_USEDEP}]"
 
 DEPEND="test? (
@@ -85,25 +87,34 @@ python_prepare_all() {
        rm spyder/plugins/ipythonconsole/tests/test_ipython_config_dialog.py || die
        rm spyder/plugins/help/tests/test_widgets.py || die
        rm spyder/plugins/help/tests/test_plugin.py  || die
+       # fails to collect
        rm spyder/app/tests/test_mainwindow.py || die
 
-       # skip uri (online) tests
-       rm spyder/plugins/editor/widgets/tests/test_goto.py || die
-
        # skip online test
        rm spyder/widgets/github/tests/test_github_backend.py || die
 
-       # Assertion error, looks like an online test
-       rm spyder/utils/tests/test_vcs.py || die
+       # AssertionError: assert 'import numpy' == '# import numpy'
+       sed -i -e 's:test_comment:_&:' \
+               spyder/plugins/editor/widgets/tests/test_codeeditor.py || die
+
+       # AssertionError: assert '' == 'This is some test text!'
+       sed -i -e 's:test_tab_copies_find_to_replace:_&:' \
+               spyder/plugins/editor/widgets/tests/test_editor.py || die
+
+       # RuntimeError: Unsafe load() call disabled by Gentoo. See bug #659348
+       sed -i -e 's:test_dependencies_for_binder_in_sync:_&:' \
+               spyder/tests/test_dependencies_in_sync.py || die
+
+       # Fatal Python error: Segmentation fault
+       sed -i -e 's:test_copy_path:_&:' \
+               spyder/plugins/explorer/widgets/tests/test_explorer.py || die
 
-               # No idea why this fails, no error just stops and dumps core
+       # No idea why this fails, no error just stops and dumps core
        sed -i -e 's:test_arrayeditor_edit_complex_array:_&:' \
                spyder/plugins/variableexplorer/widgets/tests/test_arrayeditor.py || die
 
        # Assertion error, can't connect/remember inside ebuild environment
-       sed -i -e 's:test_connection_dialog_remembers_input_with_password:_&:' \
-               -e 's:test_connection_dialog_remembers_input_with_ssh_passphrase:_&:' \
-                       spyder/plugins/ipythonconsole/widgets/tests/test_kernelconnect.py || die
+       rm spyder/plugins/ipythonconsole/widgets/tests/test_kernelconnect.py || die
 
        # Assertion error (pytest-qt), maybe we can't do shortcuts inside ebuild environment?
        sed -i -e 's:test_transform_to_uppercase_shortcut:_&:' \