dev-ros/tf: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 16:56:05 +0000 (18:56 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 17:04:24 +0000 (19:04 +0200)
Package-Manager: portage-2.2.21

dev-ros/tf/Manifest [new file with mode: 0644]
dev-ros/tf/metadata.xml [new file with mode: 0644]
dev-ros/tf/tf-1.11.7.ebuild [new file with mode: 0644]
dev-ros/tf/tf-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/tf/Manifest b/dev-ros/tf/Manifest
new file mode 100644 (file)
index 0000000..5129c8c
--- /dev/null
@@ -0,0 +1 @@
+DIST geometry-1.11.7.tar.gz 185886 SHA256 fbfbc707d239a76f7258372cb73a78341c0433d990d6f053340417c5ecb84231 SHA512 f5cf1ffdde96fc5fd375b3363192b355a2b423256bcbb9e1a7929a715b648a41919734653f9db9210fcd62a19a50c08b3c48c853dbaa4d370599732753a906e0 WHIRLPOOL 4958ca10d33d96d1d213ee778687d6d66e20bbf0b527d23bcdb4949fa8c3371831d9fe70ace862128c7018cf41f00c0280a64d9dd0eb6699dace50cf3f560b03
diff --git a/dev-ros/tf/metadata.xml b/dev-ros/tf/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/tf/tf-1.11.7.ebuild b/dev-ros/tf/tf-1.11.7.ebuild
new file mode 100644 (file)
index 0000000..f81e4cc
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between coordinate frames in a tree structure buffered in time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=[threads]
+       dev-ros/angles
+       dev-ros/message_filters
+       dev-ros/rosconsole
+       dev-ros/rostime
+       dev-ros/roscpp
+       dev-ros/tf2_ros
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/roslib[${PYTHON_USEDEP}]
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-ros/rostest[${PYTHON_USEDEP}]
+               dev-cpp/gtest
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"
diff --git a/dev-ros/tf/tf-9999.ebuild b/dev-ros/tf/tf-9999.ebuild
new file mode 100644 (file)
index 0000000..f81e4cc
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between coordinate frames in a tree structure buffered in time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=[threads]
+       dev-ros/angles
+       dev-ros/message_filters
+       dev-ros/rosconsole
+       dev-ros/rostime
+       dev-ros/roscpp
+       dev-ros/tf2_ros
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/roslib[${PYTHON_USEDEP}]
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-ros/rostest[${PYTHON_USEDEP}]
+               dev-cpp/gtest
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"