xfce-base/exo: Bump to 4.15.1
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 06:20:42 +0000 (08:20 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:03:13 +0000 (09:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/exo/Manifest
xfce-base/exo/exo-4.15.1.ebuild [new file with mode: 0644]

index 1e26e43e1964d073201e2b10f59d3140bf703b09..09c9af61e933f22a410930d6253e78e29a79d90d 100644 (file)
@@ -1 +1,2 @@
 DIST exo-0.12.11.tar.bz2 1333227 BLAKE2B 4e95809c58b6db26ecdf524663c06df9cd70007726091e381a1f0dd58be52efee85ad9721c421c0df6438073bb9de97d56cd039f520e2f7c0f5722a1839ba167 SHA512 ecbf20feddf86178d34a5c70212f0c2310ab1d6ce25291846d6d1d3045270ae3e68102065d7b3d8840137406f826f9bc37fed92a16c1268c3d14f2833a97d533
+DIST exo-4.15.1.tar.bz2 1049760 BLAKE2B 365a51a6be44b36290d1bbe7100bc4e9a164436b2111997c969bdcc2f46306c0532fa41bedc231c5640992910e44acc8d072f5c070fc8d56f02b561002985224 SHA512 46b60bfde133969a25e72a5a80644454b06543888e554e8473145486d1b1952c4e508f2303045f183c49b053969189f50316ce7d18a0be2c404daa691e26d276
diff --git a/xfce-base/exo/exo-4.15.1.ebuild b/xfce-base/exo/exo-4.15.1.ebuild
new file mode 100644 (file)
index 0000000..5089b19
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-lang/perl-5.6
+       >=dev-libs/glib-2.42
+       dev-perl/URI
+       >=x11-libs/gtk+-3.22:3
+       >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+       >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+       dev-util/gtk-doc-am
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}