dev-ml/ppx_type_conv: use proper install method.
authorAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 17:57:07 +0000 (18:57 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 20:59:02 +0000 (21:59 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild

index c8a956a358f39779b5291b6fa3cf5a048af9c951..352093921d028529584dc76c4abb8c5c735167b7 100644 (file)
@@ -6,10 +6,9 @@ EAPI="5"
 
 inherit oasis
 
-MY_P=${PN/-/_}-${PV}
 DESCRIPTION="Support Library for type-driven code generators"
 HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0/${PV}"
@@ -23,7 +22,22 @@ DEPEND="dev-ml/ppx_tools:=
        dev-ml/ppx_optcomp:="
 
 RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES.md )
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md
+}