sys-libs/libunwind: Delete obsolete code.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Sun, 1 Sep 2019 05:02:38 +0000 (05:02 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 2 Apr 2020 06:29:38 +0000 (07:29 +0100)
eutils.eclass is not used.

Broken symbolic link libunwind-generic.a is not created by build system
with --disable-static option passed since:
https://git.savannah.gnu.org/gitweb/?p=libunwind.git;a=commit;h=4e8b7a595e144e905fd9c8aed053d7529afb78a4

Bug: https://bugs.gentoo.org/693250
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/libunwind/libunwind-1.3.1.ebuild
sys-libs/libunwind/libunwind-1.4.0.ebuild

index 94aac72ea36e6de396851278f5e61be034c1c963..83400a3ec9b907a061bf4758a2e5ff320f7cf28d 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2005-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
 MY_PV=${PV/_/-}
 MY_P=${PN}-${MY_PV}
-inherit autotools eutils flag-o-matic libtool multilib-minimal
+inherit autotools flag-o-matic libtool multilib-minimal
 
 DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
 HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -53,13 +53,13 @@ src_prepare() {
        default
        chmod +x src/ia64/mk_cursor_i || die
        # Since we have tests disabled via RESTRICT, disable building in the subdir
-       # entirely.  This worksaround some build errors too. #484846
+       # entirely.  This works around some build errors too. #484846
        sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
 
        elibtoolize
        eautoreconf
 
-       # Let's wait for proer fix upstream in https://github.com/libunwind/libunwind/issues/154
+       # Let's wait for proper fix upstream in https://github.com/libunwind/libunwind/issues/154
        # Meanwhile workaround for gcc-10 with -fcommon, bug #706560
        append-cflags -fcommon
 }
@@ -99,7 +99,5 @@ multilib_src_test() {
 
 multilib_src_install() {
        default
-       # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
-       # shared library, so we keep it in any case
-       use static-libs || find "${ED}"usr '(' -name 'libunwind-generic.a' -o -name 'libunwind*.la' ')' -delete
+       use static-libs || find "${ED}"/usr -name 'libunwind*.la' -delete
 }
index 95a06d192988d28ada2d6f6c69f6f9c411d42209..9ca0fb123dc49c859769909743033c77a9efb67f 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2005-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
 MY_PV=${PV/_/-}
 MY_P=${PN}-${MY_PV}
-inherit autotools eutils flag-o-matic libtool multilib-minimal
+inherit autotools flag-o-matic libtool multilib-minimal
 
 DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
 HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -53,13 +53,13 @@ src_prepare() {
        default
        chmod +x src/ia64/mk_cursor_i || die
        # Since we have tests disabled via RESTRICT, disable building in the subdir
-       # entirely.  This worksaround some build errors too. #484846
+       # entirely.  This works around some build errors too. #484846
        sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
 
        elibtoolize
        eautoreconf
 
-       # Let's wait for proer fix upstream in https://github.com/libunwind/libunwind/issues/154
+       # Let's wait for proper fix upstream in https://github.com/libunwind/libunwind/issues/154
        # Meanwhile workaround for gcc-10 with -fcommon, bug #706560
        append-cflags -fcommon
 }
@@ -99,7 +99,5 @@ multilib_src_test() {
 
 multilib_src_install() {
        default
-       # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
-       # shared library, so we keep it in any case
-       use static-libs || find "${ED}"usr '(' -name 'libunwind-generic.a' -o -name 'libunwind*.la' ')' -delete
+       use static-libs || find "${ED}"/usr -name 'libunwind*.la' -delete
 }