dev-python/fasteners: Bump to 0.15
authorMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 06:19:11 +0000 (08:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 07:28:03 +0000 (09:28 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/fasteners/Manifest
dev-python/fasteners/fasteners-0.15.ebuild [new file with mode: 0644]

index 9641a1e2f7ca2e64dd4338193fab8e1b10398eec..39d9fd3e864cc77af441eec3c82de1f5ff190871 100644 (file)
@@ -1 +1,2 @@
 DIST fasteners-0.14.1.tar.gz 17749 BLAKE2B a1367257b495197f974712a3444d4d7f02bff2e919ecd649aac5d0fd946c128dc7592afaed4ae5044324af5d8c63fcbca6bf56eecf04e2f521dfbaceae8bbe16 SHA512 a58c5f1658b1bc664c825f2237fa91b72b9f31590e7eb79c7ae7a86c507ebe84574ac7d8e837a7bec11ad32f04204ef6f5906219b00a6adb0732daee1eb6faa1
+DIST fasteners-0.15.tar.gz 17898 BLAKE2B 58da6de627024f6b50d2f35caddfa126ee5d45ea89e16c5f14f7c42fa72e47ca9f98e1f46806b6f5e06401b25132e89113043806db1b13c2d0a095a09aa9aa69 SHA512 756f2ee8aa82ec6fd548d6e4320123b7c0bede834d4e58ff9031e004a8d9d0c23f7df4026ec4195799baa459720ca02d69a981a4aae54713e190a71152f2df9b
diff --git a/dev-python/fasteners/fasteners-0.15.ebuild b/dev-python/fasteners/fasteners-0.15.ebuild
new file mode 100644 (file)
index 0000000..b66f8cb
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package that provides useful locks"
+HOMEPAGE="https://github.com/harlowja/fasteners"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+       >=dev-python/monotonic-0.1[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+
+BDEPEND="
+       test? (
+               dev-python/testtools[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests unittest