dev-python/python-sipsimple: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 17:19:18 +0000 (19:19 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 17:35:01 +0000 (19:35 +0200)
dev-python/python-sipsimple/python-sipsimple-2.5.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-sipsimple/python-sipsimple-2.5.1-r1.ebuild b/dev-python/python-sipsimple/python-sipsimple-2.5.1-r1.ebuild
new file mode 100644 (file)
index 0000000..f3e5e3c
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="SIP SIMPLE client SDK is a Software Development Kit"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/SipClient/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="libressl"
+
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+       dev-db/sqlite:3
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+       dev-python/python-application[${PYTHON_USEDEP}]
+       media-libs/alsa-lib
+       media-libs/libv4l
+       media-libs/libvpx
+       sys-apps/util-linux
+       virtual/ffmpeg
+"
+RDEPEND="${CDEPEND}
+       dev-python/dnspython[${PYTHON_USEDEP}]
+       dev-python/python-cjson[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/python-eventlib[${PYTHON_USEDEP}]
+       dev-python/greenlet[${PYTHON_USEDEP}]
+       dev-python/python-gnutls[${PYTHON_USEDEP}]
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/python-msrplib[${PYTHON_USEDEP}]
+       dev-python/python-xcaplib[${PYTHON_USEDEP}]
+       dev-python/twisted-core[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+       dev-python/cython[${PYTHON_USEDEP}]
+       virtual/pkgconfig
+"