app-i18n/scim: Fix automagic dependencies on Qt 4.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Thu, 8 Mar 2018 19:21:03 +0000 (20:21 +0100)
committerMike Gilbert <floppym@gentoo.org>
Thu, 8 Mar 2018 19:32:51 +0000 (14:32 -0500)
Bug: https://bugs.gentoo.org/574234

app-i18n/scim/scim-1.4.14.ebuild
app-i18n/scim/scim-1.4.17.ebuild
app-i18n/scim/scim-1.4.18.ebuild

index d2595037a5cfe333a34a4285efed0f9a590f564c..ff91c1be7ca99a01d027a4b20ec3c328eba3930b 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="4"
-inherit eutils flag-o-matic multilib gnome2-utils autotools-utils
+inherit eutils flag-o-matic multilib gnome2-utils autotools-utils qmake-utils
 
 DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
 HOMEPAGE="http://www.scim-im.org/"
@@ -11,12 +11,16 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc gtk3"
+IUSE="doc gtk3 qt4"
 
 RDEPEND="x11-libs/libX11
        dev-libs/glib:2
        gtk3? ( x11-libs/gtk+:3 )
        !gtk3? ( x11-libs/gtk+:2 )
+       qt4? (
+               dev-qt/qtcore:4
+               dev-qt/qtgui:4
+       )
        >=dev-libs/atk-1
        >=x11-libs/pango-1
        !app-i18n/scim-cvs"
@@ -50,6 +54,9 @@ src_configure() {
                $(use_with doc doxygen)
                --enable-ld-version-script
                $gtk_version
+               --disable-qt3-immodule
+               $(use_enable qt4 qt4-immodule)
+               --with-qt4-moc="$(qt4_get_bindir)/moc"
        )
        autotools-utils_src_configure
 }
index 3333549b69c9f6b79e8b8d0fff212f6cef0de19f..aab97c12033138e2121c5304d641da427480d88a 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit eutils flag-o-matic multilib gnome2-utils autotools
+inherit eutils flag-o-matic multilib gnome2-utils autotools qmake-utils
 
 DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
 HOMEPAGE="https://sourceforge.net/projects/scim"
@@ -11,12 +11,16 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc gtk3"
+IUSE="doc gtk3 qt4"
 
 RDEPEND="x11-libs/libX11
        dev-libs/glib:2
        gtk3? ( x11-libs/gtk+:3 )
        !gtk3? ( x11-libs/gtk+:2 )
+       qt4? (
+               dev-qt/qtcore:4
+               dev-qt/qtgui:4
+       )
        >=dev-libs/atk-1
        >=x11-libs/pango-1"
 DEPEND="${RDEPEND}
@@ -44,7 +48,10 @@ src_configure() {
        filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
        econf $(use_with doc doxygen) \
                --enable-ld-version-script \
-               $(usex gtk3 --with-gtk-version={3,2})
+               $(usex gtk3 --with-gtk-version={3,2}) \
+               --disable-qt3-immodule \
+               $(use_enable qt4 qt4-immodule) \
+               --with-qt4-moc="$(qt4_get_bindir)/moc"
 }
 
 src_compile() {
index 775f3e68a13974fe0cd8b0a9617e76d96bd395e0..e5b61f913afba47d053b382ebe9b61fb157af505 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI="6"
 
-inherit eutils flag-o-matic multilib gnome2-utils autotools
+inherit autotools flag-o-matic gnome2-utils qmake-utils
 
 DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
 HOMEPAGE="https://github.com/scim-im/scim"
@@ -12,12 +12,16 @@ SRC_URI="https://github.com/scim-im/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc gtk3"
+IUSE="doc gtk3 qt4"
 
 RDEPEND="x11-libs/libX11
        dev-libs/glib:2
        gtk3? ( x11-libs/gtk+:3 )
        !gtk3? ( x11-libs/gtk+:2 )
+       qt4? (
+               dev-qt/qtcore:4
+               dev-qt/qtgui:4
+       )
        >=dev-libs/atk-1
        >=x11-libs/pango-1"
 DEPEND="${RDEPEND}
@@ -45,7 +49,10 @@ src_configure() {
        filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
        econf $(use_with doc doxygen) \
                --enable-ld-version-script \
-               $(usex gtk3 --with-gtk-version={3,2})
+               $(usex gtk3 --with-gtk-version={3,2}) \
+               --disable-qt3-immodule \
+               $(use_enable qt4 qt4-immodule) \
+               --with-qt4-moc="$(qt4_get_bindir)/moc"
 }
 
 src_compile() {