dev-python/catkin_pkg: bump to 0.4.15
authorAlexis Ballier <aballier@gentoo.org>
Wed, 11 Dec 2019 13:12:37 +0000 (14:12 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 11 Dec 2019 15:26:22 +0000 (16:26 +0100)
Also add py37

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-python/catkin_pkg/Manifest
dev-python/catkin_pkg/catkin_pkg-0.4.15.ebuild [new file with mode: 0644]
dev-python/catkin_pkg/catkin_pkg-9999.ebuild

index fdacd46c857cf04cdcc6b251ec933e08a14bf60b..2cdd5656431daeaa6687149e73d98877b87df66b 100644 (file)
@@ -1,2 +1,3 @@
 DIST catkin_pkg-0.4.12-gh.tar.gz 61535 BLAKE2B 9b1a60cfc6bfda6e0f126f062cf62636df162577d693aaa07c4e7433f74383686224c31e0d567a95de20e2643c39f84781be3f82b39d9dfbbd1aed0dd397587e SHA512 227a6f07a46ab62d51f408a8aa08d57199a8f4d7c954421bf9a605fce3a0dc447c9379987bcacbed3bce139f00e95bd565286a530b7177acfc29a172da30f7dd
 DIST catkin_pkg-0.4.13-gh.tar.gz 61790 BLAKE2B b879b6e71c84863fdcbca1023dd5850a226c850e47348a5ce3cfa846bd4dfb7fe0fa2c406003b4d1a0ae7ab97e57a983a499c3a27851d3101c928765c9620cdf SHA512 b971019fe2f8e66639d271ce3a7933368a4af7658d143cb042a315492926a4b0c3593dc9f784ea75150aa048266219fe80f2a104adc6d361a6725d4b24aef330
+DIST catkin_pkg-0.4.15-gh.tar.gz 63376 BLAKE2B 14eaddbc4dd544c26556033699806ee7596a0b262fc8c445696df468d3031ee63ec6c5e74c0a99569fd3faccf79202809b5e85e5ad5655d2f529d25b3d62ce1b SHA512 568f169e8fff5c4e41fdd02cbb4549dac99361a83241acbf15d3a3f2ae72f9230cab147eaa79688ce8e59d91f49096c8c57f73bb5fbfa89a41ac37aac9841f22
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.15.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.15.ebuild
new file mode 100644 (file)
index 0000000..6ddb617
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/docutils[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+DEPEND="${RDEPEND} ${BDEPEND}
+       test? (
+               dev-python/flake8[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
+RDEPEND="${RDEPEND}
+       !<dev-util/catkin-0.7.14"
+PATCHES=(
+       "${FILESDIR}/catkin_prefix2.patch"
+       "${FILESDIR}/ros_packages.patch"
+       "${FILESDIR}/infinite_loop3.patch"
+)
+
+python_test() {
+       nosetests -s --tests test || die
+}
index ceddd52d1f4273644d5b7749bd4afbd8aec808e4..6ddb6178b793a82fa6caf6e947ba4af5f9b28e27 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
 
 SCM=""
 if [ "${PV#9999}" != "${PV}" ] ; then