dev-haskell/generics-sop: new package, a depend of dev-haskell/persistent-2.6
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 08:38:38 +0000 (08:38 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:55 +0000 (10:21 +0000)
Generic Programming using True Sums of Products

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/generics-sop/Manifest [new file with mode: 0644]
dev-haskell/generics-sop/generics-sop-0.2.4.0.ebuild [new file with mode: 0644]
dev-haskell/generics-sop/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/generics-sop/Manifest b/dev-haskell/generics-sop/Manifest
new file mode 100644 (file)
index 0000000..c04bc56
--- /dev/null
@@ -0,0 +1 @@
+DIST generics-sop-0.2.4.0.tar.gz 32986 SHA256 481f73f122970efc24fe9dea71077e265d260834d975dd41395671d9a86a1863 SHA512 ce0d92214e622c58febced5684ba92b117e413d5718c6fdea1471f0fc5ea48ea53b212a536618086228542985f304dc4434c75c6ab919a72e6f49ccce342d866 WHIRLPOOL 8ee0469f5a9685b904bd7d86a8949cf3f527c8f0d207632b796f215499d9864fea3766e185536109dbf722f6395c4bed9e49e66a695dd748afb19510dbc04012
diff --git a/dev-haskell/generics-sop/generics-sop-0.2.4.0.ebuild b/dev-haskell/generics-sop/generics-sop-0.2.4.0.ebuild
new file mode 100644 (file)
index 0000000..61f9a0a
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic Programming using True Sums of Products"
+HOMEPAGE="http://hackage.haskell.org/package/generics-sop"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.6:=[profile?]
+       >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.18.1.3
+"
diff --git a/dev-haskell/generics-sop/metadata.xml b/dev-haskell/generics-sop/metadata.xml
new file mode 100644 (file)
index 0000000..af04114
--- /dev/null
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               A library to support the definition of generic functions.
+               Datatypes are viewed in a uniform, structured way:
+               the choice between constructors is represented using an n-ary
+               sum, and the arguments of each constructor are represented using
+               an n-ary product.
+               
+               The module "Generics.SOP" is the main module of this library and contains
+               more detailed documentation.
+               
+               Examples of using this library are provided by the following
+               packages:
+               
+               * @&lt;https://hackage.haskell.org/package/basic-sop basic-sop&gt;@ basic examples,
+               
+               * @&lt;https://hackage.haskell.org/package/pretty-sop pretty-sop&gt;@ generic pretty printing,
+               
+               * @&lt;https://hackage.haskell.org/package/lens-sop lens-sop&gt;@ generically computed lenses,
+               
+               * @&lt;https://hackage.haskell.org/package/json-sop json-sop&gt;@ generic JSON conversions.
+               
+               A detailed description of the ideas behind this library is provided by
+               the paper:
+               
+               * Edsko de Vries and Andres Löh.
+               &lt;http://www.andres-loeh.de/TrueSumsOfProducts True Sums of Products&gt;.
+               Workshop on Generic Programming (WGP) 2014.
+               
+       </longdescription>
+</pkgmetadata>