net-wireless/hackrf-tools: install easy flash for live
authorRick Farina <zerochaos@gentoo.org>
Mon, 23 Sep 2019 16:11:51 +0000 (12:11 -0400)
committerRick Farina <zerochaos@gentoo.org>
Mon, 23 Sep 2019 16:20:00 +0000 (12:20 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/hackrf-tools/hackrf-tools-9999.ebuild

index 667c6b35b87196afc9b87f4ae326c529f3bc5289..57c399314261e0ffc3215f10f84f82d0960da401 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit cmake-utils
 
@@ -30,6 +30,7 @@ RDEPEND="${DEPEND}"
 
 src_install() {
        cmake-utils_src_install
+       dosbin "${FILESDIR}/hackrf_easy_flash"
        if [[ ${PV} != "9999" ]] ; then
                insinto /usr/share/hackrf
                newins "${WORKDIR}/hackrf-${PV}/firmware-bin/hackrf_jawbreaker_usb.bin" hackrf_jawbreaker_usb-${PV}.bin
@@ -43,5 +44,6 @@ src_install() {
                ln -s hackrf_one_usb-${PV}.dfu "${ED}/usr/share/hackrf/hackrf_one_usb.dfu"
        else
                ewarn "The compiled firmware files are only available in the versioned releases, you are on your own for this."
+               ewarn "A hackrf-firmware ebuild is available in the pentoo overlay, if you feel adventurous."
        fi
 }