dev-python/plyvel: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:14:02 +0000 (17:14 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:14:02 +0000 (17:14 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/plyvel/plyvel-1.0.5.ebuild
dev-python/plyvel/plyvel-1.1.0.ebuild

index 953e10d1c72d7ee25decae6a8bc8ae8b8c7f1485..8e5a110b4ae70765484e4ce888b70aa5a5704b1a 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 # Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{5,6,7} )
 
 inherit distutils-r1
 
@@ -28,12 +28,6 @@ DEPEND="
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
 "
 
-python_compile() {
-       # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
-       python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
 python_compile_all() {
        if use doc; then
                sphinx-build doc doc/_build/html || die
index e03758e6af931f6c6fd6e9dca16377d327870867..577a79b89443cb95e30e9bf9c50cdcff900a4e5f 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 # Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{5,6,7} )
 
 inherit distutils-r1
 
@@ -28,12 +28,6 @@ DEPEND="
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
 "
 
-python_compile() {
-       # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
-       python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
 python_compile_all() {
        if use doc; then
                sphinx-build doc doc/_build/html || die