dev-erlang/p1_oauth2: Version bump
authorHanno Böck <hanno@gentoo.org>
Wed, 1 Apr 2020 09:40:57 +0000 (11:40 +0200)
committerHanno Böck <hanno@gentoo.org>
Wed, 1 Apr 2020 09:40:57 +0000 (11:40 +0200)
Signed-off-by: Hanno Böck <hanno@gentoo.org>
Package-Manager: Portage-2.3.96, Repoman-2.3.22

dev-erlang/p1_oauth2/Manifest
dev-erlang/p1_oauth2/p1_oauth2-0.6.6.ebuild [new file with mode: 0644]

index 5766de592d5910c0c18ff8a4ad1ddfd4b431f390..892aca86c169b2f64f11e86ed710bcd9ba865ab7 100644 (file)
@@ -1,2 +1,3 @@
 DIST p1_oauth2-0.6.1.tar.gz 212804 BLAKE2B 571341aaa4d3a4bac6ac2f8f46d2e4b9caf5e00622a392635d79ff11b520a3cab71d360220c99a46035ce851974d975d69a71ac9b1be626c9b126941fc4a73cf SHA512 2509d48775579a26178fb5a082e628a8487c986b1b4d4abe974b653a1e0b7605bed934d59f6d62927582bdb95a53ba454816d326d99a77c5360928c4973ade4a
 DIST p1_oauth2-0.6.5.tar.gz 213847 BLAKE2B de1b9dc238efacf5682ad12b1b563fc311f1e0515673003286b31f42ebd33fb8dd9e384aed194047cd6ab38d4769ab128e8de5241004ce49f72d56ad9ca22d21 SHA512 5664aba423c85d90321533878b73e58b50d7ef3bc4183c8108c99e075ef4e75041eb28620de4dc14be23dfaac3623a858a9c8e191e54dae62eb9688ea0812312
+DIST p1_oauth2-0.6.6.tar.gz 213866 BLAKE2B 2b7ff13697658c6ab31a2cab60100758d965ae0f3cbeb878539e42210e54e7cf33a458c645e432790f79ba3fa92ab35a5d6d6136edc14369ac6d8872e16d7f69 SHA512 9680bc96608bc486165d5f77cf6e92e5f9257e0dbea718c739563556c2b485f67152dcd99cbe228addd34b33b2dd6cc9eacc3827f269412f705acd14b2522952
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.6.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.6.ebuild
new file mode 100644 (file)
index 0000000..bf2fd79
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang OAuth 2.0 implementation"
+HOMEPAGE="https://github.com/processone/p1_oauth2"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+       -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+       test? (
+               >=dev-erlang/meck-0.8.7
+               >=dev-erlang/proper-1.3
+       )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+       rebar_src_prepare
+       rebar_remove_deps rebar.test.config
+}
+
+src_test() {
+       erebar -C rebar.test.config compile eunit
+}