dev-python/photoutils: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:50:32 +0000 (19:50 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:50:32 +0000 (19:50 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/photutils/Manifest [deleted file]
dev-python/photutils/metadata.xml [deleted file]
dev-python/photutils/photutils-0.3.1.ebuild [deleted file]
dev-python/photutils/photutils-0.3.2.ebuild [deleted file]

diff --git a/dev-python/photutils/Manifest b/dev-python/photutils/Manifest
deleted file mode 100644 (file)
index d75e5e1..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST photutils-0.3.1.tar.gz 633814 BLAKE2B 362fda6922f0fa192f383e52dc30b7e02e63d215486d895c3d8ed88784709c1f7758c4206ba7d4116d8b64586fb2804a1495964dc4ad67fd6eff74cfcc0e51b0 SHA512 62f7b838e09cb76d0c3b400524340861d882455d305fc31bb062c5853018f0133a4364a5b5e5166101328ad931d474823dd59ab7e58fdcb68bd824dd2ed34959
-DIST photutils-0.3.2.tar.gz 634159 BLAKE2B 8297ed77059b6bbe3cbd92b7aefb79886b88741fafea43f44cac9eff86a02c24e7e7c1428ae70259e3d2d2590eb61f8b864d9edf3dcecd340aa82b095644b32a SHA512 69c845cee9e16ab9daa26e87bbd209f9159fbba4cbcbae1eea9e84bf4ab75b7723964bde30ecec4004d00a80370ed599d867d8314675700485eb6190c7aa0300
diff --git a/dev-python/photutils/metadata.xml b/dev-python/photutils/metadata.xml
deleted file mode 100644 (file)
index b72b596..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
-    photutils is a python package for determining photometric properties
-    of sources in astronomical images. This includes source detection,
-    centroid and shape parameters, and performing photometry.
-  </longdescription>
-  <upstream>
-    <remote-id type="pypi">photutils</remote-id>
-    <remote-id type="github">astropy/photutils</remote-id>
-  </upstream>
-</pkgmetadata>
diff --git a/dev-python/photutils/photutils-0.3.1.ebuild b/dev-python/photutils/photutils-0.3.1.ebuild
deleted file mode 100644 (file)
index 63d149f..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python package for image astronomical photometry"
-HOMEPAGE="https://photutils.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DOCS=( README.rst )
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       sci-libs/scikits_image[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       export MPLCONFIGDIR="${T}"
-       echo "backend: Agg" > "${MPLCONFIGDIR}"/matplotlibrc
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               python_setup
-               VARTEXFONTS="${T}"/fonts \
-                                  PYTHONPATH="${BUILD_DIR}"/lib \
-                                  esetup.py build_sphinx --no-intersphinx
-       fi
-}
-
-python_test() {
-       virtx esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/photutils/photutils-0.3.2.ebuild b/dev-python/photutils/photutils-0.3.2.ebuild
deleted file mode 100644 (file)
index c5c9829..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python package for image astronomical photometry"
-HOMEPAGE="https://photutils.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DOCS=( README.rst )
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       sci-libs/scikits_image[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       export MPLCONFIGDIR="${T}"
-       echo "backend: Agg" > "${MPLCONFIGDIR}"/matplotlibrc
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               python_setup
-               VARTEXFONTS="${T}"/fonts \
-                                  PYTHONPATH="${BUILD_DIR}"/lib \
-                                  esetup.py build_sphinx --no-intersphinx
-       fi
-}
-
-python_test() {
-       virtx esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}