dev-python/http-parser: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:22 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:22 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/http-parser/http-parser-0.8.3.ebuild

index 534c30604b62e0b7a6c52107c9c3c92763d1f33e..5337b6d3494675a84ad7db444bc18866fd1a7b3e 100644 (file)
@@ -32,6 +32,10 @@ python_compile() {
 
 python_install_all() {
        local DOCS=( README.rst )
-       use examples && local EXAMPLES=( examples/. )
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install_all
 }