dev-python/packaging: Allow installation without setuptools
authorJustin Lecher <jlec@gentoo.org>
Fri, 28 Aug 2015 06:33:22 +0000 (08:33 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 28 Aug 2015 06:40:02 +0000 (08:40 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/packaging/files/packaging-15.3-setuptools.patch [new file with mode: 0644]
dev-python/packaging/packaging-15.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/packaging/files/packaging-15.3-setuptools.patch b/dev-python/packaging/files/packaging-15.3-setuptools.patch
new file mode 100644 (file)
index 0000000..abb0662
--- /dev/null
@@ -0,0 +1,30 @@
+ setup.py | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 13c9dad..9d68590 100644
+--- a/setup.py
++++ b/setup.py
+@@ -15,7 +15,12 @@
+ from __future__ import absolute_import, division, print_function
+ import os
+-import setuptools
++
++try:
++    from setuptools import setup
++except ImportError:
++    from distutils.core import setup
++
+ base_dir = os.path.dirname(__file__)
+@@ -31,7 +36,7 @@ with open(os.path.join(base_dir, "CHANGELOG.rst")) as f:
+     long_description = "\n".join([long_description, f.read()])
+-setuptools.setup(
++setup(
+     name=about["__title__"],
+     version=about["__version__"],
diff --git a/dev-python/packaging/packaging-15.3-r1.ebuild b/dev-python/packaging/packaging-15.3-r1.ebuild
new file mode 100644 (file)
index 0000000..f43c596
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3  )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pretend[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-setuptools.patch )
+
+python_test() {
+       py.test --capture=no --strict -v || die
+}