sys-apps/fwupd: Fixed build with USE="-agent man"
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 6 Mar 2020 15:22:26 +0000 (16:22 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 6 Mar 2020 15:22:58 +0000 (16:22 +0100)
Thanks-to: Joakim Tjernlund <joakim.tjernlund@infinera.com>
Closes: https://bugs.gentoo.org/711682
Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/fwupd/files/fwupd-1.3.9-optional_agent_man_page.patch [new file with mode: 0644]
sys-apps/fwupd/fwupd-1.3.9.ebuild

diff --git a/sys-apps/fwupd/files/fwupd-1.3.9-optional_agent_man_page.patch b/sys-apps/fwupd/files/fwupd-1.3.9-optional_agent_man_page.patch
new file mode 100644 (file)
index 0000000..6c98985
--- /dev/null
@@ -0,0 +1,57 @@
+From bacd3a44fe6f06ddd8bb65a3a56eb1738a65ed8c Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 6 Mar 2020 16:00:23 +0100
+Subject: [PATCH] Don't build/install fwupdagent man page if agent build is not
+ requested
+
+Otherwise build fails with:
+
+  src/meson.build:196:2: ERROR: Unknown variable "fwupdagent".
+
+Gentoo-bug: https://bugs.gentoo.org/711682
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ src/meson.build | 30 ++++++++++++++++--------------
+ 1 file changed, 16 insertions(+), 14 deletions(-)
+
+diff --git a/src/meson.build b/src/meson.build
+index 46a9c4ded..e9aac607e 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -193,20 +193,22 @@ if build_daemon and get_option('man')
+     install : true,
+     install_dir : join_paths(mandir, 'man1'),
+   )
+-  custom_target('fwupdagent-man',
+-    input : fwupdagent,
+-    output : 'fwupdagent.1',
+-    command : [
+-      help2man, '@INPUT@',
+-      '--no-info',
+-      '--output', '@OUTPUT@',
+-      '--name', 'Firmware updating agent',
+-      '--manual', 'User Commands',
+-      '--version-string', fwupd_version,
+-    ],
+-    install : true,
+-    install_dir : join_paths(mandir, 'man1'),
+-  )
++  if get_option('agent')
++    custom_target('fwupdagent-man',
++      input : fwupdagent,
++      output : 'fwupdagent.1',
++      command : [
++        help2man, '@INPUT@',
++        '--no-info',
++        '--output', '@OUTPUT@',
++        '--name', 'Firmware updating agent',
++        '--manual', 'User Commands',
++        '--version-string', fwupd_version,
++      ],
++      install : true,
++      install_dir : join_paths(mandir, 'man1'),
++    )
++  endif
+ endif
+ if get_option('man')
+   custom_target('fwupdtool-man',
index a10af44195eaf3103f1fb1c388ca6914bfc2da54..03fab547386751b5fa64834b56d2d378e1d74999 100644 (file)
@@ -93,6 +93,7 @@ RDEPEND="
 
 PATCHES=(
        "${FILESDIR}/${PN}-1.3.9-logind_plugin.patch"
+       "${FILESDIR}/${P}-optional_agent_man_page.patch"
 )
 
 pkg_setup() {