www-apps/drupal: bump to 8.8.0 and 7.68 releases.
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Thu, 5 Dec 2019 16:41:44 +0000 (15:41 -0100)
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Thu, 5 Dec 2019 16:41:44 +0000 (15:41 -0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
www-apps/drupal/Manifest
www-apps/drupal/drupal-7.68.ebuild [new file with mode: 0644]
www-apps/drupal/drupal-8.8.0.ebuild [new file with mode: 0644]

index 25f2dd2f8209ea5af6c54da6d34e56f3ff8c6c4b..ef97bec9f103ce63cf4b4029c4fa9353bf47b0c4 100644 (file)
@@ -1,5 +1,7 @@
 DIST drupal-7.67.tar.gz 3312764 BLAKE2B bb7f21e80ca192ff3e37f917c1fa43dcd8d3cd8b60ff012d1fe22e279ffd674e08be6aef6328d0c5b7c50a106592bde299300fe9ccb0c4c1ffc1aca57c3ca6ad SHA512 0e4f60010b1395183cea19424e8c2849f93fb7285a081bf7d0c774b8e82f403083533059f58c3831950cc06dfa8117d443db52b66a521301ceac10b1b333aa28
+DIST drupal-7.68.tar.gz 3314177 BLAKE2B 915369e8b1af0676347d326ae5a23194a6643a079b89c83c12c93edccabc0f4eecd472d0007007f9c58ae8ecec0b9850eb8f0ea3488398d7bbccd105d1246aa5 SHA512 b6e9cd1ac002cf5b633b3bc5431e4159a1e49530860f60137960cf102a04b00cbd8bfe0687b98524348ef48e1f24f858808caf9d3305c973e24bd0d92479ba2a
 DIST drupal-8.6.16.tar.gz 17151378 BLAKE2B 2bdd14ff7a5f898af2d322a6b2862643899dfbe2ad05c99b85f036161612cccfc2c25105c8eef37311634a2aa03ed792db8de3e625aed5adb94cd8f644557fcb SHA512 34f260d780bce286a0a61b710c340d2622cb857aa92a2bdaad63737303ef2f4f1751edc3f415daaa14b9cb483757e367e639136d03f571cba5165129bba31e12
 DIST drupal-8.7.10.tar.gz 17894144 BLAKE2B cf20860bc11ca65a7ff0808e533f5c3aac39d4f5b0f9052601d1bf510cdc28bb5fca99d14d78badc61158f06742e1fb6addfc4145ad17720095631f7258b0cd7 SHA512 c614a64efd86c529d89f4411d4418731ae85cf0af5a236dd3a475f68dd4d408fb7c6d378477897e2ce68c71cc287f218dab2d45cc3d96967a75a6500e0161716
 DIST drupal-8.7.8.tar.gz 17882836 BLAKE2B 8a521c5c615356548eea8a64ee81e31082e3b9c5ed37c66fef7f2f3c426c7339e4848b90306cfccae1005c5c6d8fe8d7964662012da66c9c6754c6052d102173 SHA512 cc68e6318ebc162cd50fe19046a992ae2ca338f9da564a12a88954edb2c0cecaa56b0ded22903f67f305ab1fee48dd8a2bbf8b65a9efda2e1ce50d11b97bab28
 DIST drupal-8.7.9.tar.gz 17888541 BLAKE2B 958779c7ae8fa1527ae91d3174c19afc311682c4bbceacd6592796abf781b4e52b0e1ad5f020bd79d2d55508a954bf969076121d703f69959afd6b7a87b6e9b9 SHA512 6181af0e096974e1eb7d5a046d8f34372725891937fcce7d9c0b6b1dffebc0d6fc3519f16df6edbea35c081231c9f8411166f66586cb932de1e6aadebfa78cb1
+DIST drupal-8.8.0.tar.gz 19404952 BLAKE2B 4cdad86e3668f80c45a3cff79ca0d245e36e2239d0a97f06ebe05cf125a0665e16eb75410fccb0ac5cae5a7a5e909ec67649fc4ec5e14e78b887c6b8981e7f77 SHA512 26a2f064c951b712a944ef68903070c51262f6886482429b893809ee2b2a3a58974937e9c9a698d1476eb17c38c532ede73ba4cc4ff3e2d80e989ae6cd188664
diff --git a/www-apps/drupal/drupal-7.68.ebuild b/www-apps/drupal/drupal-7.68.ebuild
new file mode 100644 (file)
index 0000000..da5fce8
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+       dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+       virtual/httpd-php
+       uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+       webapp_src_preinst
+
+       local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+       dodoc ${docs}
+       rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+       cp sites/default/{default.settings.php,settings.php} || die
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       dodir "${MY_HTDOCSDIR}"/files
+       webapp_serverowned "${MY_HTDOCSDIR}"/files
+       webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+       webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+       webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+       webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+       webapp_src_install
+}
+
+pkg_postinst() {
+       echo
+       ewarn "SECURITY NOTICE"
+       ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+       ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+       echo
+}
diff --git a/www-apps/drupal/drupal-8.8.0.ebuild b/www-apps/drupal/drupal-8.8.0.ebuild
new file mode 100644 (file)
index 0000000..945c43d
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+       dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+       virtual/httpd-php
+       uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+       webapp_src_preinst
+
+       local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+               core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+       dodoc ${docs}
+       rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+       cp sites/default/{default.settings.php,settings.php} || die
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       dodir "${MY_HTDOCSDIR}"/files
+       webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+       webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+       webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+       webapp_src_install
+}
+
+pkg_postinst() {
+       echo
+       ewarn "SECURITY NOTICE"
+       ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+       ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+       echo
+       ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+       ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+       echo
+       ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+       ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+       ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+       ewarn "reported by the setup."
+       echo
+}