dev-python/genshi-0.7.3-r1: revbump, fix setuptools dep, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 04:11:15 +0000 (21:11 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 04:11:59 +0000 (21:11 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/genshi/genshi-0.7.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/genshi/genshi-0.7.3-r1.ebuild b/dev-python/genshi/genshi-0.7.3-r1.ebuild
new file mode 100644 (file)
index 0000000..7c06bf7
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python toolkit for stream-based generation of output for the web"
+HOMEPAGE="http://genshi.edgewall.org/ https://pypi.org/project/Genshi/"
+SRC_URI="mirror://pypi/G/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P^}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+       if use doc; then
+               dodoc doc/*.txt
+       fi
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}