dev-python/pytest-xprocess: fix broken tests
authorVirgil Dupras <vdupras@gentoo.org>
Sat, 25 Aug 2018 17:40:21 +0000 (13:40 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sat, 25 Aug 2018 17:41:02 +0000 (13:41 -0400)
Closes: https://bugs.gentoo.org/664542
Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild

index 8677f37ccd253399e4b11dff15f9e8856de0b270..b749a2cba7df4b1a849fc6ba05ced6a9087c488e 100644 (file)
@@ -24,9 +24,8 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 
 python_test() {
-       cd example || die
        # Upstream's package mistakenly includes __pycache__ directory that make
        # tests fail.
-       rm -rf __pycache__ || die
+       rm -rf example/__pycache__ || die
        pytest -v || die
 }