dev-util/hadolint: Version bump to 1.4.0
authorManuel Rüger <mrueg@gentoo.org>
Mon, 5 Feb 2018 15:52:37 +0000 (16:52 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Mon, 5 Feb 2018 15:52:37 +0000 (16:52 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-util/hadolint/Manifest
dev-util/hadolint/hadolint-1.4.0.ebuild [new file with mode: 0644]

index 3554c04068361ab0cdd419e6a9017f6affc7cd48..f47db6c5dff9782a3d18fd7e1928de02e54bbc35 100644 (file)
@@ -1,2 +1,3 @@
 DIST hadolint-1.2.6.tar.gz 26761 BLAKE2B bf2693b0073cef553a2f7767a2d90a3af009cebbfeb448b306475f5ec6c7a3e9b228cab5e2279b6a3c3387be0fd58f14c47df1cd21c35045f96f3f3e07678ae5 SHA512 36f25dc040aa93c45f6da8195de7089032c0b777f939aafd77b53103d662d977b372afd7a6e39840498df6496a2a29a8c94ae59748b599aa840824fe28dda8b4
 DIST hadolint-1.3.0.tar.gz 27014 BLAKE2B 9142319c8c275e78890ebaa002817a6d9b6beb5df0caf48000276d4f4fc6df780f6474790dae83c2d45074d5752b9dd482cc9b3266e4f404256144b53719db72 SHA512 6ac01e354849336375efba67870ba655e14424919d6c8d3c40ee246c7ddf1b2946a5d8a74d8bbaba45a2827895f9a18f6dbc042e41b2c44f97be3c615546f27c
+DIST hadolint-1.4.0.tar.gz 28384 BLAKE2B ee5fb556d99375b0628dd8eade076e98899301a122cec9cda1b1198da150b7a5ea1bae84e6550ab05efe0d079e926a7e16f76d873203be3e03ca428f1201a6d9 SHA512 a91c72bf08f98696ac7267268f10293837da402d3d71e042d9bde69affdbc7d0c42bcbd30756a84bbb021d100f1a200362c9fc28c5fbba87903b4cbf695931d2
diff --git a/dev-util/hadolint/hadolint-1.4.0.ebuild b/dev-util/hadolint/hadolint-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..2f335d9
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Dockerfile Linter JavaScript API"
+HOMEPAGE="https://github.com/hadolint/hadolint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/gitrev-1.3.1:=[profile?]
+       >=dev-haskell/language-docker-2.0.0:=[profile?]
+       <=dev-haskell/optparse-applicative-0.14.0.0:=[profile?]
+       >=dev-haskell/parsec-3.1:=[profile?]
+       >=dev-haskell/split-0.2:=[profile?]
+       dev-haskell/yaml:=[profile?]
+       >=dev-lang/ghc-8.0.2:=
+       >=dev-util/shellcheck-0.4.7:=[profile?]
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.24.2.0
+       test? ( dev-haskell/hspec
+               >=dev-haskell/hunit-1.2 )
+"
+
+src_prepare() {
+       default
+       sed -i -e "s/-static//" ${PN}.cabal || die
+}