dev-python/ldappool: 2.4.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 04:37:01 +0000 (23:37 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:04:51 +0000 (02:04 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/ldappool/Manifest
dev-python/ldappool/ldappool-2.4.1.ebuild [new file with mode: 0644]

index d7118f388d01010c0fc9a7a6af1cae529ff3b6ad..5e5634f190ff489bce235547cabb3c098518c633 100644 (file)
@@ -2,3 +2,4 @@ DIST ldappool-1.0.tar.gz 6795 BLAKE2B 139175ddfa9dadb32b047a13e29ce4ac593abbc926
 DIST ldappool-2.0.0.tar.gz 15089 BLAKE2B 0fc5f930657d500bbc317f180d96dd66c04bbf1c24b3de7acf5542d61380a3419dd5375b3ffac6d602ac4b62005a8d6e73ed088ae716801e562187e6c11672e5 SHA512 824243cca712d6aef8929c74cb15f0cefbc8795cdb599d3b0cc48e8eee4a58d3db94a6642379f87ba011784c289f936a62f2aed637bb005985bbee2118d3b6ea
 DIST ldappool-2.1.0.tar.gz 16395 BLAKE2B 1cfd13f35e5224dad53d5346b2cf064ae8afdde8a04cf71a3af079b05f2b4e5f66e51523fde16ab128cbbef55f29629252237b78cb0a8fb8270c563ca5a52f52 SHA512 a261a4a68e159a54eae51dc19ed543398a1be61d305ba3958d4dab9ed2de9787203a418e5d754cf12c503e5a4c2e8d180d609968e6407201548d4c4886526c0c
 DIST ldappool-2.3.1.tar.gz 16125 BLAKE2B 2fd2da35fa8f4b7d7f1e85107528595fe83ee771193ddb1099357607a98a90a43d8f7d64a364e323d5b127d989b6ca68d1325593806f66d50c35cdb4f85580f4 SHA512 7cf5eddc39ba5fd51151a5af6f728dd1ba15521abaeb2ddac7a19fa59e987b92eb6dd4d4ce505e715edcc650702248248bdc1a0f7ef4366220b7799e42a7dfbe
+DIST ldappool-2.4.1.tar.gz 18611 BLAKE2B 44de0b3b3c4ef94e232189216e55c0adf85b51e4d6e2e7c47a6c9dca455e9e09919bc04e264e027e4ba96af8dc7315a78e5094f5ed2ccd4c8f6c3952da38370f SHA512 ea22290d9acc7f90093cb27aacbf339e1edbad33780051db263cc5254d0b42494e6dd67da9f5e506f09c5867a69afbea89d14e0c3aac47233cba0ffe361b1a75
diff --git a/dev-python/ldappool/ldappool-2.4.1.ebuild b/dev-python/ldappool/ldappool-2.4.1.ebuild
new file mode 100644 (file)
index 0000000..8368cfa
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for python-ldap"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+       >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       >=dev-python/python-ldap-3.0.0[${PYTHON_USEDEP}]
+       >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+"