app-arch/unshield: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 13:05:18 +0000 (15:05 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 13:05:18 +0000 (15:05 +0200)
app-arch/unshield/unshield-0.6_p20120308-r1.ebuild [new file with mode: 0644]

diff --git a/app-arch/unshield/unshield-0.6_p20120308-r1.ebuild b/app-arch/unshield/unshield-0.6_p20120308-r1.ebuild
new file mode 100644 (file)
index 0000000..778549d
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="https://github.com/twogood/unshield http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="libressl static-libs"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+       sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-bootstrap.patch
+       ./bootstrap
+       sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467548
+       AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --with-ssl
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dodoc README
+
+       find "${D}" -name '*.la' -exec rm -f {} +
+}