dev-libs/elfio: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sat, 12 Oct 2019 08:09:21 +0000 (10:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 12 Oct 2019 08:09:21 +0000 (10:09 +0200)
Closes: https://bugs.gentoo.org/694168
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/elfio/Manifest [deleted file]
dev-libs/elfio/elfio-1.0.3-r1.ebuild [deleted file]
dev-libs/elfio/files/elfio-1.0.3-shared.patch [deleted file]
dev-libs/elfio/metadata.xml [deleted file]
profiles/package.mask

diff --git a/dev-libs/elfio/Manifest b/dev-libs/elfio/Manifest
deleted file mode 100644 (file)
index 0dd5515..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST ELFIO-1.0.3.tar.gz 308560 BLAKE2B 60316124f87ac0a3fadd959a6699431b01d79aa071fa18c4b3518f4c42fe9131b867287227694b2a46aca89b9a11347ed936327e6c08760a47738ef71b9ea5c7 SHA512 eb0194ccc9e5194b7ac4ee7dfed06269e5235e72dd72631b63dcc3b0b44c76d44aa30df1332e7424e08ab905d2b243af6e2c183be87766536d588fa6ff719f19
diff --git a/dev-libs/elfio/elfio-1.0.3-r1.ebuild b/dev-libs/elfio/elfio-1.0.3-r1.ebuild
deleted file mode 100644 (file)
index 8edb94f..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-MY_P="ELFIO-${PV}"
-DESCRIPTION="ELF reader and producer implemented as a C++ library"
-HOMEPAGE="http://elfio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/elfio/${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/${P}-shared.patch" )
-
-src_prepare() {
-       default
-       eautoreconf
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-       dodoc AUTHORS NEWS README
-}
diff --git a/dev-libs/elfio/files/elfio-1.0.3-shared.patch b/dev-libs/elfio/files/elfio-1.0.3-shared.patch
deleted file mode 100644 (file)
index 01e67df..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-diff -ur ELFIO-1.0.3.orig/configure.in ELFIO-1.0.3/configure.in
---- ELFIO-1.0.3.orig/configure.in      2007-03-06 16:36:26.000000000 +0100
-+++ ELFIO-1.0.3/configure.in   2007-03-06 16:37:08.000000000 +0100
-@@ -7,6 +7,7 @@
- AC_PROG_CXX
- AC_PROG_RANLIB
- AC_PROG_INSTALL
-+AC_PROG_LIBTOOL
- dnl Checks for libraries.
-diff -ur ELFIO-1.0.3.orig/ELFIO/Makefile.am ELFIO-1.0.3/ELFIO/Makefile.am
---- ELFIO-1.0.3.orig/ELFIO/Makefile.am 2007-03-06 16:36:26.000000000 +0100
-+++ ELFIO-1.0.3/ELFIO/Makefile.am      2007-03-06 16:36:45.000000000 +0100
-@@ -1,6 +1,6 @@
--lib_LIBRARIES = libELFIO.a
-+lib_LTLIBRARIES = libELFIO.la
--libELFIO_a_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
-+libELFIO_la_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
-     ELFIOUtils.cpp ELFIRelocation.cpp ELFISection.cpp \
-     ELFISegment.cpp ELFIStrings.cpp ELFISymbols.cpp \
-     ELFODynamic.cpp ELFOImpl.cpp ELFONote.cpp \
-@@ -10,4 +10,4 @@
- include_HEADERS = ELFI.h ELFIO.h ELFO.h ELFTypes.h
- noinst_HEADERS  = ELFIImpl.h ELFOImpl.h ELFIOUtils.h
--EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
-\ No newline at end of file
-+EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
-diff -ur ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am ELFIO-1.0.3/Examples/ELFDump/Makefile.am
---- ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am      2007-03-06 16:36:26.000000000 +0100
-+++ ELFIO-1.0.3/Examples/ELFDump/Makefile.am   2007-03-06 16:37:51.000000000 +0100
-@@ -3,6 +3,6 @@
- bin_PROGRAMS = ELFDump
- ELFDump_SOURCES = ELFDump.cpp
--ELFDump_LDADD = ../../ELFIO/libELFIO.a
-+ELFDump_LDADD = ../../ELFIO/libELFIO.la
- EXTRA_DIST = ELFDump.dsp ELFDump.dsw ELFDump.mcp
-diff -ur ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am ELFIO-1.0.3/Examples/RelocationTable/Makefile.am
---- ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am      2007-03-06 16:36:26.000000000 +0100
-+++ ELFIO-1.0.3/Examples/RelocationTable/Makefile.am   2007-03-06 16:38:53.000000000 +0100
-@@ -3,6 +3,6 @@
- noinst_PROGRAMS = RelocationTable
- RelocationTable_SOURCES = RelocationTable.cpp
--RelocationTable_LDADD = ../../ELFIO/libELFIO.a
-+RelocationTable_LDADD = ../../ELFIO/libELFIO.la
- EXTRA_DIST = RelocationTable.mcp
-diff -ur ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am ELFIO-1.0.3/Examples/WriteObj/Makefile.am
---- ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am     2007-03-06 16:36:26.000000000 +0100
-+++ ELFIO-1.0.3/Examples/WriteObj/Makefile.am  2007-03-06 16:39:28.000000000 +0100
-@@ -3,6 +3,6 @@
- noinst_PROGRAMS = WriteObj
- WriteObj_SOURCES = WriteObj.cpp
--WriteObj_LDADD = ../../ELFIO/libELFIO.a
-+WriteObj_LDADD = ../../ELFIO/libELFIO.la
- EXTRA_DIST = WriteObj.dsp WriteObj.dsw WriteObj.mcp
-diff -ur ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am ELFIO-1.0.3/Examples/WriteObj2/Makefile.am
---- ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am    2007-03-06 16:36:26.000000000 +0100
-+++ ELFIO-1.0.3/Examples/WriteObj2/Makefile.am 2007-03-06 16:39:40.000000000 +0100
-@@ -3,4 +3,4 @@
- noinst_PROGRAMS = WriteObj2
- WriteObj2_SOURCES = WriteObj2.cpp
--WriteObj2_LDADD = ../../ELFIO/libELFIO.a
-+WriteObj2_LDADD = ../../ELFIO/libELFIO.la
-diff -ur ELFIO-1.0.3.orig/Examples/Writer/Makefile.am ELFIO-1.0.3/Examples/Writer/Makefile.am
---- ELFIO-1.0.3.orig/Examples/Writer/Makefile.am       2007-03-06 16:36:26.000000000 +0100
-+++ ELFIO-1.0.3/Examples/Writer/Makefile.am    2007-03-06 16:39:10.000000000 +0100
-@@ -3,6 +3,6 @@
- noinst_PROGRAMS = Writer
- Writer_SOURCES = Write.cpp
--Writer_LDADD = ../../ELFIO/libELFIO.a
-+Writer_LDADD = ../../ELFIO/libELFIO.la
- EXTRA_DIST = Writer.dsp Writer.dsw Writer.mcp
diff --git a/dev-libs/elfio/metadata.xml b/dev-libs/elfio/metadata.xml
deleted file mode 100644 (file)
index a797d0a..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <!-- maintainer-needed -->
-       <upstream>
-               <remote-id type="sourceforge">elfio</remote-id>
-       </upstream>
-</pkgmetadata>
index 3d06a54cc247055e52e133d20d372dc4e4a2770a..90f06a87d8473cbeb0408aa9d7ba9067053696f1 100644 (file)
@@ -740,12 +740,6 @@ dev-libs/hashit
 # Removal in 30 days.  Bug #694170.
 dev-libs/fampp2
 
-# Michał Górny <mgorny@gentoo.org> (2019-09-12)
-# Unmaintained.  The current release is from 2005, pending version bump
-# since 2012.  No reverse dependencies.
-# Removal in 30 days.  Bug #694168.
-dev-libs/elfio
-
 # Lars Wendler <polynomial-c@gentoo.org> (2019-09-04)
 # Unofficial build. Superseded by official 2.49.5 release.
 # Masked for removal.