gnome-base/gnome-settings-daemon: version bump
authorGilles Dartiguelongue <eva@gentoo.org>
Sun, 23 Aug 2015 15:33:57 +0000 (17:33 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Sun, 23 Aug 2015 15:39:01 +0000 (17:39 +0200)
Package-Manager: portage-2.2.20.1

gnome-base/gnome-settings-daemon/Manifest
gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.16.3.ebuild [new file with mode: 0644]

index 8f36769b8b20979fbc7fd15332962a1967fb28f3..d883b7d22033cebf45dd6dae92a1f59a90459b2e 100644 (file)
@@ -1,3 +1,4 @@
 DIST gnome-settings-daemon-3.14.2.tar.xz 1612184 SHA256 066bc8ed751c5f6b5a9590911a0fb2b51b0c3436ae1caccfa42e0791c34fedee SHA512 3cd125ed89d47b03439f473df861d41696f6281c9df84218f3fe29d86570fbcd13dd2bedb3f63b354e06043d7d8fda0d1304e03a6ca39b9bcbd369a908d88ba2 WHIRLPOOL 157195486a9ed8db18fe851ea8a567d2c53beeaf3cfc6d21f5e25a876f2e5b6847ccb6e848bae6accdd3861c96b16a0bfd5642f8e0fce3f8c3d4923599d49260
 DIST gnome-settings-daemon-3.14.4.tar.xz 1650276 SHA256 ce4453f83a19328e4f031251430325cb6ae832b83fa9fce80a8cde1d4bb0a2a5 SHA512 c6c62f7e13f93fd3dcff7990571289e10c9ef341ebb9d6deab67adf705a32a13142b7e8aebccd4a71d39f191a472d427fdea5acebc5fcf6f6106c641af320a32 WHIRLPOOL 145e694c74364f6fec6543976cf1e0abb6049f8a13c8f0c8b95a481d849a94255f68ade1a4926f0207c19cdbc8927f55edbcae68b01e7ef95046c3786cb07cbb
 DIST gnome-settings-daemon-3.16.2.tar.xz 1602508 SHA256 d8d536584ebb8fb1403050eb65e7ee3328eba14b123542369ff1917e727fa69a SHA512 04f62429b6f3edf6d7c11b0fbe8b5b74a3be3d6309ec7a9019dc77d2f8557ad26242a210bcfb36b393b99d93c33590c595c6d7dca9c1272f04bdf5cfc7144076 WHIRLPOOL 95f69752b3a9ad7d22489123555cd84dffb6c0ac4872dd5febbfb444013eb2417a0f50f53b311f640cc3d4ac8b662c0b2a102fbe3e32de0614161ed9cf646579
+DIST gnome-settings-daemon-3.16.3.tar.xz 1651880 SHA256 8752f79ba2ee76701744b4806140d1b88c665ad7cd44e7ff58b4e78e1063daea SHA512 d11c16b9ccf17683c0917ed8bee8b5142bfcc3d2099073df5318e8a1f801a9b7e07f2dfe68818edee568d6fb2cc8571580b072c1de46dc22aee4bbffddfc3ff5 WHIRLPOOL 1dec35ba84975bd297b69622733ab33db981a4b569cf67711f8b526bc3285515ca8fd522131888f6419459d6382ac493aed54b073a4e5950a837cca3f55f2ccf
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.16.3.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.16.3.ebuild
new file mode 100644 (file)
index 0000000..1af881d
--- /dev/null
@@ -0,0 +1,152 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit autotools eutils gnome2 python-r1 systemd udev virtualx
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="https://git.gnome.org/browse/gnome-settings-daemon"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+colord +cups debug input_devices_wacom -openrc-force networkmanager policykit +short-touchpad-timeout smartcard test +udev wayland"
+REQUIRED_USE="
+       input_devices_wacom? ( udev )
+       smartcard? ( udev )
+       test? ( ${PYTHON_REQUIRED_USE} )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.37.7:2[dbus]
+       >=x11-libs/gtk+-3.15.3:3
+       >=gnome-base/gnome-desktop-3.11.1:3=
+       >=gnome-base/gsettings-desktop-schemas-3.15.4
+       >=gnome-base/librsvg-2.36.2
+       media-fonts/cantarell
+       media-libs/fontconfig
+       >=media-libs/lcms-2.2:2
+       media-libs/libcanberra[gtk3]
+       >=media-sound/pulseaudio-2
+       >=sys-power/upower-0.99:=
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/libnotify-0.7.3:=
+       x11-libs/libX11
+       x11-libs/libxkbfile
+       x11-libs/libXi
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXtst
+       x11-libs/libXxf86misc
+       x11-misc/xkeyboard-config
+
+       >=app-misc/geoclue-2.1.2:2.0
+       >=dev-libs/libgweather-3.9.5:2
+       >=sci-geosciences/geocode-glib-3.10
+       >=sys-auth/polkit-0.103
+
+       colord? ( >=x11-misc/colord-1.0.2:= )
+       cups? ( >=net-print/cups-1.4[dbus] )
+       input_devices_wacom? (
+               >=dev-libs/libwacom-0.7
+               >=x11-libs/pango-1.20
+               x11-drivers/xf86-input-wacom
+               virtual/libgudev:= )
+       networkmanager? ( >=net-misc/networkmanager-0.9.9.1 )
+       smartcard? ( >=dev-libs/nss-3.11.2 )
+       udev? ( virtual/libgudev:= )
+       wayland? ( dev-libs/wayland )
+"
+# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
+# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
+# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
+# systemd needed for power and session management, bug #464944
+RDEPEND="${COMMON_DEPEND}
+       gnome-base/dconf
+       !openrc-force? ( sys-apps/systemd )
+       >=x11-themes/gnome-themes-standard-2.91
+       >=x11-themes/gnome-icon-theme-2.91
+       >=x11-themes/gnome-icon-theme-symbolic-2.91
+       !<gnome-base/gnome-control-center-2.22
+       !<gnome-extra/gnome-color-manager-3.1.1
+       !<gnome-extra/gnome-power-manager-3.1.3
+"
+# xproto-7.0.15 needed for power plugin
+DEPEND="${COMMON_DEPEND}
+       cups? ( sys-apps/sed )
+       test? (
+               ${PYTHON_DEPS}
+               dev-python/pygobject[${PYTHON_USEDEP}] )
+       dev-libs/libxml2:2
+       sys-devel/gettext
+       >=dev-util/intltool-0.40
+       virtual/pkgconfig
+       x11-proto/inputproto
+       x11-proto/xf86miscproto
+       >=x11-proto/xproto-7.0.15
+"
+
+src_prepare() {
+       # https://bugzilla.gnome.org/show_bug.cgi?id=621836
+       # Apparently this change severely affects touchpad usability for some
+       # people, so revert it if USE=short-touchpad-timeout.
+       # Revisit if/when upstream adds a setting for customizing the timeout.
+       use short-touchpad-timeout &&
+               epatch "${FILESDIR}"/${PN}-3.7.90-short-touchpad-timeout.patch
+
+       # Make colord and wacom optional; requires eautoreconf
+       epatch "${FILESDIR}"/${PN}-3.16.0-optional.patch
+
+       epatch_user
+       eautoreconf
+
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               --enable-man \
+               $(use_enable colord color) \
+               $(use_enable cups) \
+               $(use_enable debug) \
+               $(use_enable debug more-warnings) \
+               $(use_enable networkmanager network-manager) \
+               $(use_enable smartcard smartcard-support) \
+               $(use_enable udev gudev) \
+               $(use_enable input_devices_wacom wacom) \
+               $(use_enable wayland)
+}
+
+src_test() {
+       python_export_best
+       Xemake check
+}
+
+src_install() {
+       gnome2_src_install udevrulesdir="$(get_udevdir)"/rules.d #509484
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       if ! systemd_is_booted; then
+               ewarn "${PN} needs Systemd to be *running* for working"
+               ewarn "properly. Please follow the this guide to migrate:"
+               ewarn "http://wiki.gentoo.org/wiki/Systemd"
+       fi
+
+       if use openrc-force; then
+               ewarn "You are enabling 'openrc-force' USE flag to skip systemd requirement,"
+               ewarn "this can lead to unexpected problems and is not supported neither by"
+               ewarn "upstream neither by Gnome Gentoo maintainers. If you suffer any problem,"
+               ewarn "you will need to disable this USE flag system wide and retest before"
+               ewarn "opening any bug report."
+       fi
+}