games-roguelike/nethack: Depend on acct-group/gamestat.
authorUlrich Müller <ulm@gentoo.org>
Mon, 8 Jul 2019 08:48:47 +0000 (10:48 +0200)
committerUlrich Müller <ulm@gentoo.org>
Tue, 16 Jul 2019 09:15:27 +0000 (11:15 +0200)
Bug: https://bugs.gentoo.org/689464
Acked-by: Luis Ressel <aranea@aixah.de>
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
games-roguelike/nethack/nethack-3.6.0-r3.ebuild
games-roguelike/nethack/nethack-3.6.1.ebuild

index fa9302932cb1192e85b2e7e035cfaff0d98c1365..834881ef5f28211262912ae737b90c69051af7bb 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit eutils toolchain-funcs flag-o-matic user
+inherit eutils toolchain-funcs flag-o-matic
 
 MY_PV=${PV//.}
 DESCRIPTION="The ultimate old-school single player dungeon exploration game"
@@ -14,7 +14,8 @@ SLOT="0"
 KEYWORDS="~amd64 ~arm ~hppa ~x86 ~x86-fbsd"
 IUSE="experimental X"
 
-RDEPEND="sys-libs/ncurses:0=
+RDEPEND="acct-group/gamestat
+       sys-libs/ncurses:0=
        X? (
                x11-libs/libXaw
                x11-libs/libXpm
@@ -35,8 +36,6 @@ NETHACK_GROUP="gamestat"
 
 pkg_setup() {
        HACKDIR="/usr/$(get_libdir)/${PN}"
-
-       enewgroup gamestat 36
 }
 
 src_prepare() {
index 783a9ec4f644d5db807a42ed87c6f4457a4b6a67..b2a450c706dbec69dc4db417f6fe072c713c217a 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-inherit desktop flag-o-matic toolchain-funcs user
+inherit desktop flag-o-matic toolchain-funcs
 
 MY_PV=${PV//.}
 DESCRIPTION="The ultimate old-school single player dungeon exploration game"
@@ -14,7 +14,8 @@ SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
 IUSE="X"
 
-RDEPEND="sys-libs/ncurses:0=
+RDEPEND="acct-group/gamestat
+       sys-libs/ncurses:0=
        X? (
                x11-libs/libXaw
                x11-libs/libXpm
@@ -96,8 +97,6 @@ src_install() {
 }
 
 pkg_preinst() {
-       enewgroup gamestat 36
-
        fowners root:gamestat /var/games/nethack /var/games/nethack/save
        fperms 2770 /var/games/nethack /var/games/nethack/save