dev-ml/camlidl: disable warnings so that it build with ocaml 4.03
authorAlexis Ballier <aballier@gentoo.org>
Tue, 1 Mar 2016 19:37:21 +0000 (20:37 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 2 Mar 2016 19:29:06 +0000 (20:29 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/camlidl/camlidl-1.05-r1.ebuild
dev-ml/camlidl/files/nowarn.patch [new file with mode: 0644]

index ea4debe95b7bd5f25f5c8fee142b006316abcad6..496779c37870e6af7d9291fa9edbc17e523e2335 100644 (file)
@@ -19,6 +19,7 @@ RDEPEND="${DEPEND}"
 src_prepare() {
        epatch "${FILESDIR}/tests.patch"
        epatch "${FILESDIR}/includes.patch"
+       epatch "${FILESDIR}/nowarn.patch"
 }
 
 src_compile() {
diff --git a/dev-ml/camlidl/files/nowarn.patch b/dev-ml/camlidl/files/nowarn.patch
new file mode 100644 (file)
index 0000000..8b457cf
--- /dev/null
@@ -0,0 +1,13 @@
+Index: camlidl-1.05/compiler/Makefile
+===================================================================
+--- camlidl-1.05.orig/compiler/Makefile
++++ camlidl-1.05/compiler/Makefile
+@@ -29,7 +29,7 @@ PROG=camlidl$(EXE)
+ all: $(PROG)
+ $(PROG): $(OBJS)
+-      $(OCAMLC) -o $(PROG) $(OBJS)
++      $(OCAMLC) -w -a -o $(PROG) $(OBJS)
+ clean::
+       rm -f $(PROG)