dev-vcs/cvsgraph: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Wed, 6 Nov 2019 10:11:19 +0000 (11:11 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 6 Nov 2019 10:11:19 +0000 (11:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild

index ada216280c8bba9463ccdb2dd065a8fd4e429b56..b844f9cff8ead000c08713ed9f3f9dac28b00853 100644 (file)
@@ -1,15 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="CVS/RCS repository grapher"
 HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
 SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
-KEYWORDS="-alpha amd64 -ia64 ppc sparc x86"
+KEYWORDS="amd64 ppc sparc x86"
 IUSE="gif jpeg nls png truetype zlib"
 
 DEPEND="media-libs/gd
@@ -20,16 +20,13 @@ DEPEND="media-libs/gd
        truetype? ( media-libs/freetype )"
 RDEPEND="${DEPEND}"
 
-src_compile() {
+src_configure() {
        econf \
                $(use_enable nls) \
                $(use_enable gif) \
                $(use_enable png) \
                $(use_enable jpeg) \
-               $(use_enable truetype) \
-               || die "econf failed"
-
-       emake || die "emake failed"
+               $(use_enable truetype)
 }
 
 src_install () {
@@ -38,5 +35,5 @@ src_install () {
        doins cvsgraph.conf
        doman cvsgraph.1 cvsgraph.conf.5
        dodoc ChangeLog README AUTHORS contrib/*.php
-       docinto automatic_documentation ; dodoc contrib/automatic_documentation/*
+       dodoc -r contrib/automatic_documentation
 }