dev-util/vulkan-headers: Bump vulkan-headers-1.1.125
authorPeter Levine <plevine457@gmail.com>
Mon, 21 Oct 2019 01:57:19 +0000 (21:57 -0400)
committerNick Sarnie <sarnex@gentoo.org>
Mon, 21 Oct 2019 22:48:19 +0000 (18:48 -0400)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Peter Levine <plevine457@gmail.com>
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
dev-util/vulkan-headers/Manifest
dev-util/vulkan-headers/vulkan-headers-1.1.125.ebuild [new file with mode: 0644]

index c743874ef5b947361435cc92efad331d50e5645c..8cf0539ffd0e70a988ea6dbfa4d2cee29d98be22 100644 (file)
@@ -1 +1,2 @@
 DIST vulkan-headers-1.1.114.tar.gz 596033 BLAKE2B 707b820ab37e7de92540196c181dea7a0ef1461e15f2b39f4a8355f265ec8d422e69987f3e49f210b8e9f8ebe20f99a682805b2c9b94755f94d2a1b2213b67d5 SHA512 6da91d7207575437f4322ddcacda25f85910266012625a2485124d8dc7d91d88386cc8d93ae5ded4f9e7d862b7139573118df550022ec912a5b2685048cbc6ce
+DIST vulkan-headers-1.1.125.tar.gz 662594 BLAKE2B 7cd18b74ff804ed02df3378485f0783332bd09bf898769c48ded20f7a6495b5208cfae3616de401e17ffcec30421b48222520dcd90b03ad83b548405fd8a656c SHA512 355df13347aaa3b32ad62185810c20d1b2f358525d9d8036f6bc7643e7505a25c087a51e05fa7b0758e4ee63221bb39d01d6e14bfb7f99a53cb2127ca5db5d67
diff --git a/dev-util/vulkan-headers/vulkan-headers-1.1.125.ebuild b/dev-util/vulkan-headers/vulkan-headers-1.1.125.ebuild
new file mode 100644 (file)
index 0000000..c02bab4
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Headers.git"
+       inherit git-r3
+else
+       if [[ -z ${SNAPSHOT_COMMIT} ]]; then
+               MY_PV=v${PV}
+               MY_P=Vulkan-Headers-${PV}
+       else
+               MY_PV=${SNAPSHOT_COMMIT}
+               MY_P=Vulkan-Headers-${SNAPSHOT_COMMIT}
+       fi
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/KhronosGroup/Vulkan-Headers/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}"/${MY_P}
+fi
+
+DESCRIPTION="Vulkan Header files and API registry"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
+
+LICENSE="Apache-2.0"
+SLOT="0"