Revert "media-libs/gstreamer: fix bug #577312"
authorAnthony G. Basile <blueness@gentoo.org>
Tue, 10 May 2016 23:38:49 +0000 (19:38 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 10 May 2016 23:39:56 +0000 (19:39 -0400)
This reverts commit f59f39fb234fe5ce1c2a4c1c63be575fa494302c.

The gstreamer folks made a mistake in backporting this form libcheck.

See https://bugzilla.gnome.org/show_bug.cgi?id=763567#c12

media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch [deleted file]
media-libs/gstreamer/gstreamer-1.6.3.ebuild

diff --git a/media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch b/media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch
deleted file mode 100644 (file)
index e237f9b..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From c9da8b0e7f53005ab125e48165dae39fbfee2352 Mon Sep 17 00:00:00 2001
-From: "Anthony G. Basile" <blueness@gentoo.org>
-Date: Sun, 13 Mar 2016 11:05:29 -0400
-Subject: libcompat.h: strsignal() should be not be decleared const
-
-POSIX standards requires strsignal() to return a pointer to a char,
-not a const pointer to a char. [1]  On uClibc, and possibly other
-libc's, that do not HAVE_DECL_STRSIGNAL, libcompat.h declares
-const char *strsignal (int sig) which causes a type error.
-
-[1] man 3 strsignal
-
-https://bugzilla.gnome.org/show_bug.cgi?id=763567
-
-diff --git a/libs/gst/check/libcheck/strsignal.c b/libs/gst/check/libcheck/strsignal.c
-index b79409b..57e71cd 100644
---- a/libs/gst/check/libcheck/strsignal.c
-+++ b/libs/gst/check/libcheck/strsignal.c
-@@ -1,6 +1,6 @@
- #include "libcompat.h"
--const char *
-+char *
- strsignal (int sig)
- {
-   static char signame[40];
--- 
-cgit v0.10.2
-
index 63ff72f9f12c5a94c214a6afd8eb9c46b5817599..3b778476c233ce5dcc9effc57248c199c125103c 100644 (file)
@@ -30,10 +30,6 @@ DEPEND="${RDEPEND}
 "
 # gtk-doc-am to install API docs
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-fix-strsignal.patch #577312
-}
-
 src_configure() {
        if [[ ${CHOST} == *-interix* ]] ; then
                export ac_cv_lib_dl_dladdr=no