dev-util/rosinstall_generator: initial import. ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 17 Sep 2015 11:25:11 +0000 (13:25 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 17 Sep 2015 11:25:11 +0000 (13:25 +0200)
Package-Manager: portage-2.2.20.1

dev-util/rosinstall_generator/Manifest [new file with mode: 0644]
dev-util/rosinstall_generator/metadata.xml [new file with mode: 0644]
dev-util/rosinstall_generator/rosinstall_generator-0.1.11.ebuild [new file with mode: 0644]
dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild [new file with mode: 0644]

diff --git a/dev-util/rosinstall_generator/Manifest b/dev-util/rosinstall_generator/Manifest
new file mode 100644 (file)
index 0000000..57e114c
--- /dev/null
@@ -0,0 +1 @@
+DIST rosinstall_generator-0.1.11.tar.gz 10230 SHA256 cbb87d76a35d14d9dc5728c53e0027fe855830daacf6b4aa78b336fad03a297d SHA512 ec94feaf05f105cc19715824937c96a505bcff1236a445f8eb85cd68dfa70fd8e146d6e8c67a5f1d54b1579a8f432ecbf042acd7c0a78a104c27281433afb2f6 WHIRLPOOL e78320c5134f6645ab168695b4a5291fda8348a38f0b5f3a27618e0c6a9eac04381a843f1eb083db9e1f4edb149e8ac767e6ded6691894dec604504e582fce34
diff --git a/dev-util/rosinstall_generator/metadata.xml b/dev-util/rosinstall_generator/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-0.1.11.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-0.1.11.ebuild
new file mode 100644 (file)
index 0000000..608b89c
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/rosinstall_generator"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Generates rosinstall files containing information about repositories with ROS packages/stacks"
+HOMEPAGE="http://wiki.ros.org/rosinstall_generator"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ros-infrastructure/rosinstall_generator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       >=dev-python/catkin_pkg-0.1.28[${PYTHON_USEDEP}]
+       dev-python/rosdistro[${PYTHON_USEDEP}]
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
new file mode 100644 (file)
index 0000000..608b89c
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/rosinstall_generator"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Generates rosinstall files containing information about repositories with ROS packages/stacks"
+HOMEPAGE="http://wiki.ros.org/rosinstall_generator"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ros-infrastructure/rosinstall_generator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       >=dev-python/catkin_pkg-0.1.28[${PYTHON_USEDEP}]
+       dev-python/rosdistro[${PYTHON_USEDEP}]
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"