old, part of bug 330683
authorSamuli Suominen <ssuominen@gentoo.org>
Wed, 19 Oct 2011 16:12:13 +0000 (16:12 +0000)
committerSamuli Suominen <ssuominen@gentoo.org>
Wed, 19 Oct 2011 16:12:13 +0000 (16:12 +0000)
Package-Manager: portage-2.2.0_alpha69/cvs/Linux x86_64

dev-games/crystalspace/ChangeLog
dev-games/crystalspace/crystalspace-1.2.1.ebuild [deleted file]
dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch [deleted file]

index bc219d81309ce9eae34e1f13b788f83e1a7e525e..794d917f2530245a14f8cea5947eef734ff62548 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-games/crystalspace
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.53 2011/09/09 09:25:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.54 2011/10/19 16:12:13 ssuominen Exp $
+
+  19 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
+  -crystalspace-1.2.1.ebuild, -files/crystalspace-1.2.1-libpng14.patch:
+  old
 
   09 Sep 2011; Tupone Alfredo <tupone@gentoo.org> crystalspace-1.4.0.ebuild,
   +files/crystalspace-1.4.0-png15.patch:
diff --git a/dev-games/crystalspace/crystalspace-1.2.1.ebuild b/dev-games/crystalspace/crystalspace-1.2.1.ebuild
deleted file mode 100644 (file)
index 89b8e39..0000000
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.2.1.ebuild,v 1.8 2011/07/20 13:26:19 tomka Exp $
-
-EAPI=2
-inherit eutils flag-o-matic multilib wxwidgets
-
-MY_P=${PN}-src-${PV}
-DESCRIPTION="Portable 3D Game Development Kit written in C++"
-HOMEPAGE="http://crystal.sourceforge.net/"
-SRC_URI="mirror://sourceforge/crystal/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="3ds alsa cal3d cegui cg doc javascript jpeg mng ode png python
-sdl truetype vorbis wxwidgets"
-
-RDEPEND="virtual/opengl
-       cg? ( media-gfx/nvidia-cg-toolkit )
-       ode? ( dev-games/ode )
-       cal3d? ( >=media-libs/cal3d-0.11 )
-       jpeg? ( virtual/jpeg )
-       sdl? ( media-libs/libsdl )
-       vorbis? ( media-libs/libogg
-               media-libs/libvorbis )
-       truetype? ( >=media-libs/freetype-2.1 )
-       alsa? ( media-libs/alsa-lib )
-       mng? ( media-libs/libmng )
-       png? ( media-libs/libpng )
-       wxwidgets? ( x11-libs/pango
-               =x11-libs/wxGTK-2.6* )
-       javascript? ( dev-lang/spidermonkey )
-       cegui? ( >=dev-games/cegui-0.5.0 )
-       x11-libs/libXaw
-       x11-libs/libXxf86vm"
-DEPEND="${RDEPEND}
-       3ds? ( media-libs/lib3ds )
-       dev-util/ftjam
-       dev-lang/swig
-       dev-util/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       # Installing doc conflict with dodoc on src_install
-       # Removing conflicting target
-       sed -i \
-               -e "/^InstallDoc/d" \
-               Jamfile.in \
-               docs/Jamfile \
-               || die "sed failed"
-
-       epatch "${FILESDIR}"/${P}-libpng14.patch
-}
-
-src_configure() {
-       if use wxwidgets; then
-               WX_GTK_VER=2.6
-               need-wxwidgets gtk2
-       fi
-
-       # -O3 is hanging compilation of python script plugin
-       # trying -O2 just in case
-       replace-flags -O3 -O2
-       econf --enable-cpu-specific-optimizations=no \
-               --disable-separate-debug-info \
-               --without-lcms \
-               --without-caca \
-               --without-bullet \
-               --without-openal \
-               --without-jackasyn \
-               --without-mikmod \
-               --without-perl \
-               --without-java \
-               --disable-make-emulation \
-               $(use_with python) \
-               $(use_with png) \
-               $(use_with jpeg) \
-               $(use_with mng) \
-               $(use_with vorbis) \
-               $(use_with 3ds) \
-               $(use_with ode) \
-               $(use_with truetype freetype2) \
-               $(use_with cal3d) \
-               $(use_with sdl) \
-               $(use_with wxwidgets wx) \
-               $(use_with cegui CEGUI) \
-               $(use_with cg Cg) \
-               $(use_with javascript js) \
-               $(use_with alsa asound)
-       #remove unwanted CFLAGS added by ./configure
-       sed -i -e '/COMPILER\.CFLAGS\.optimize/d' \
-               Jamconfig \
-               || die "sed failed"
-}
-
-src_compile() {
-       jam -q || die "compile failed"
-}
-
-src_install() {
-       for installTarget in install_bin install_plugin install_lib \
-               install_include install_data install_config
-       do
-               jam -q -s DESTDIR="${D}" ${installTarget} \
-                       || die "jam ${installTarget} failed"
-       done
-       if use doc; then
-               jam -q -s DESTDIR="${D}" install_doc || die "jam install_doc failed"
-       fi
-       dodoc README docs/history* docs/todo_*
-
-       echo "CRYSTAL_PLUGIN=/usr/$(get_libdir)/${P}" > 90crystalspace
-       echo "CRYSTAL_CONFIG=/etc/${P}" >> 90crystalspace
-       doenvd 90crystalspace
-}
-
-pkg_postinst() {
-       elog "Examples coming with this package, need correct light calculation"
-       elog "Do the following commands, with the root account, to fix that:"
-       # Fill cache directory for the examples
-       local dir
-       for dir in castle flarge isomap parallaxtest partsys r3dtest stenciltest \
-               terrain terrainf;
-       do
-               elog "cslight -video=null /usr/share/${PN}/data/maps/${dir}"
-       done
-}
diff --git a/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch b/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch
deleted file mode 100644 (file)
index 2ee262d..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-http://trac.crystalspace3d.org/trac/CS/ticket/803
-
---- plugins/video/loader/png/pngimage.cpp
-+++ plugins/video/loader/png/pngimage.cpp
-@@ -378,7 +378,7 @@
-   const png_bytep iBuffer = dataSource->GetUint8();
-   const size_t iSize = dataSource->GetSize();
--  if (!png_check_sig (iBuffer, (int)iSize))
-+  if (png_sig_cmp (iBuffer, 0, (int)iSize) != 0)
-     return false;
-   png = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
-   if (!png)