Revert "dev-db/oracle-instantclient-jdbc: cleanup old"
authorMichael Haubenwallner <haubi@gentoo.org>
Mon, 9 Jul 2018 19:49:50 +0000 (21:49 +0200)
committerMichael Haubenwallner <haubi@gentoo.org>
Mon, 9 Jul 2018 19:52:04 +0000 (21:52 +0200)
This reverts commit fdaa33ab2b75287eb555cc5a98d5b2cc94f7ee32.

There have been stable keywords around.

dev-db/oracle-instantclient-jdbc/Manifest [new file with mode: 0644]
dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild [new file with mode: 0644]
dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.4.ebuild [new file with mode: 0644]

diff --git a/dev-db/oracle-instantclient-jdbc/Manifest b/dev-db/oracle-instantclient-jdbc/Manifest
new file mode 100644 (file)
index 0000000..d92783f
--- /dev/null
@@ -0,0 +1,4 @@
+DIST instantclient-jdbc-linux-11.2.0.3.0.zip 1562543 BLAKE2B 7f32c39cb7c4fbdd54db0015e081bc8d913e9570c4651d2e41f17155f2a77772826ec823adaf36b44d1264ff686c3735835a483f3cd1551a1f5274c028692fd3 SHA512 f78991e57eed2b095e8659825723bfc107d3c4519d1864769a0190f22e3d5667a1a4213a067470a8fb07c1f0562ec950c9fbe37f70e9475811dd1edfaf3f17f0
+DIST instantclient-jdbc-linux-11.2.0.4.0.zip 1562440 BLAKE2B e3f377802958b22aede4d91c9bc16a85f5c0ff2cec3066a4a49f5c71ab90c17f9b7c6f29da146304327569cb3d5d533a3807941e4061254e0cf57a8387a55b04 SHA512 0a92a6529642203d48846d3f22f3756ada22942ea5e7c36d779d220dc7195301d4016edd8ee5124f9e51429bb77d9890602c1a18884eec58ff40c2aed24e55f9
+DIST instantclient-jdbc-linux.x64-11.2.0.3.0.zip 1562504 BLAKE2B 07f0753ff2add12924d05c6a4b4d07356726c7ca7d8a3118e0d65bf30db04eb89aeb0255591583714cd168782313eb083764d6ca9ed64b2081dc119c46222114 SHA512 afb824786e01f316dfa244e304fae7d9a34f4175de8ff6622bed116a9810bfca9ec5eceda6a1de95d46f7170fb63f1345dc1886efd168f1daa8c8498d2b3c8d7
+DIST instantclient-jdbc-linux.x64-11.2.0.4.0.zip 1562474 BLAKE2B f93a05ad324bb364ddab83b0bc75f6c0bc8d7224f53cf337c9887f99e07c98a8752e7d4581b19ca38c70bbe3fcf1b492d753f715bed7ba8144f37c03cc9524c0 SHA512 289a08bddc81687b73a42fb35ae6ea294dd8f536ae9d3e95142ab78ad72eeebf66947fa6f5585e48e35b7f92e65fe6a295fb564b8353d389e76bfecf35c48c18
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild
new file mode 100644 (file)
index 0000000..303d9db
--- /dev/null
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_PLAT_x86="Linux x86"
+MY_A_x86="${PN/oracle-/}-linux-${PV}.0.zip"
+
+MY_PLAT_amd64="Linux x86-64"
+MY_A_amd64="${PN/oracle-/}-linux.x64-${PV}.0.zip"
+
+DESCRIPTION="Oracle 11g Instant Client: JDBC supplement"
+HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
+SRC_URI="
+       x86?   ( ${MY_A_x86}                             )
+       amd64? ( ${MY_A_amd64} multilib? ( ${MY_A_x86} ) )
+"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="fetch"
+IUSE="multilib"
+
+DEPEND="app-arch/unzip"
+RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/lib*/oracle/${PV}/client/lib*/lib*"
+
+default_abi() {
+       [[ ${DEFAULT_ABI} == 'default' ]] && echo ${ARCH} || echo ${DEFAULT_ABI}
+}
+
+abi_list() {
+       if use multilib; then
+               echo ${MULTILIB_ABIS}
+       else
+               default_abi
+       fi
+       return 0
+}
+
+set_abivars() {
+       local abi=$1
+       # platform name
+       MY_PLAT=MY_PLAT_${abi}
+       MY_PLAT=${!MY_PLAT}
+       # runtime distfile
+       MY_A=MY_A_${abi}
+       MY_A=${!MY_A}
+       # abi sourcedir
+       MY_S="${S}/${abi}/instantclient_11_2"
+       # ABI might not need to be set at all
+       [[ -n ${ABI} ]] && MY_ABI=${abi} || MY_ABI=
+       # abi libdir
+       MY_LIBDIR=$(ABI=${MY_ABI} get_libdir)
+}
+
+pkg_nofetch() {
+       eerror "Please go to"
+       eerror "  ${HOMEPAGE%/*}/index-097480.html"
+       eerror "  and download"
+       local abi
+       for abi in $(abi_list)
+       do
+               set_abivars ${abi}
+               eerror "Instant Client for ${MY_PLAT}"
+               eerror "    JDBC: ${MY_A}"
+       done
+       eerror "After downloading, put them in:"
+       eerror "    ${DISTDIR}/"
+}
+
+src_unpack() {
+       local abi
+       for abi in $(abi_list)
+       do
+               set_abivars ${abi}
+               mkdir -p "${MY_S%/*}" || die
+               cd "${MY_S%/*}" || die
+               unpack ${MY_A}
+       done
+}
+
+src_install() {
+       # all binaries go here
+       local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client
+       into "${oracle_home}"
+
+       local abi
+       for abi in $(abi_list)
+       do
+               set_abivars ${abi}
+               einfo "Installing runtime for ${MY_PLAT} ..."
+
+               cd "${MY_S}" || die
+
+               ABI=${MY_ABI} dolib.so lib*$(get_libname)*
+
+               insinto "${oracle_home}"/${MY_LIBDIR}
+               doins *.jar
+
+               eend $?
+       done
+}
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.4.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.4.ebuild
new file mode 100644 (file)
index 0000000..75696a7
--- /dev/null
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils multilib-minimal
+
+MY_PLAT_x86="Linux x86"
+MY_A_x86="${PN/oracle-/}-linux-${PV}.0.zip"
+
+MY_PLAT_amd64="Linux x86-64"
+MY_A_amd64="${PN/oracle-/}-linux.x64-${PV}.0.zip"
+
+DESCRIPTION="Oracle 11g Instant Client: JDBC supplement"
+HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
+SRC_URI="
+       abi_x86_32? ( ${MY_A_x86}   )
+       abi_x86_64? ( ${MY_A_amd64} )
+"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="fetch splitdebug"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/lib*/oracle/${PV}/client/lib*/lib*"
+
+set_my_abivars() {
+       MY_PLAT=MY_PLAT_${ABI}; MY_PLAT=${!MY_PLAT} # platform name
+       MY_A=MY_A_${ABI}      ; MY_A=${!MY_A}       # runtime distfile
+       # ABI sourcedir
+       MY_S="${S}/${ABI}/instantclient_11_2"
+
+       [[ -n ${MY_PLAT} ]]
+}
+
+pkg_nofetch() {
+       eerror "Please go to"
+       eerror "  ${HOMEPAGE%/*}/index-097480.html"
+       eerror "  and download"
+       local ABI
+       for ABI in $(multilib_get_enabled_abis)
+       do
+               set_my_abivars || continue
+               eerror "Instant Client for ${MY_PLAT}"
+               eerror "    JDBC: ${MY_A}"
+       done
+       eerror "After downloading, put them in:"
+       eerror "    ${DISTDIR}/"
+}
+
+src_unpack() {
+       local ABI
+       for ABI in $(multilib_get_enabled_abis)
+       do
+               set_my_abivars || continue
+               mkdir -p "${MY_S%/*}" || die
+               cd "${MY_S%/*}" || die
+               unpack ${MY_A}
+       done
+}
+
+src_install() {
+       # all binaries go here
+       local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client
+       into "${oracle_home}"
+
+       local ABI
+       for ABI in $(multilib_get_enabled_abis)
+       do
+               if ! set_my_abivars; then
+                       elog "Skipping unsupported ABI ${ABI}."
+                       continue
+               fi
+               einfo "Installing runtime for ${MY_PLAT} ..."
+
+               cd "${MY_S}" || die
+
+               dolib.so lib*$(get_libname)*
+
+               insinto "${oracle_home}"/$(get_libdir)
+               doins *.jar
+
+               eend $?
+       done
+}