dev-perl/CQL-Parser: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Thu, 7 May 2020 13:44:11 +0000 (01:44 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 7 May 2020 13:53:50 +0000 (01:53 +1200)
- EAPI7
- Parallel tests
- Use "patch" instead of "sed"
- Fix license as best I can re bug #721472

Bug: https://bugs.gentoo.org/721472
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild [new file with mode: 0644]
dev-perl/CQL-Parser/files/CQL-Parser-1.13-no-dot-inc.patch [new file with mode: 0644]

diff --git a/dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild b/dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild
new file mode 100644 (file)
index 0000000..c10924c
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BRICAS
+DIST_VERSION=1.13
+inherit perl-module
+
+DESCRIPTION="compiles CQL strings into parse trees of Node subtypes"
+# Bug: https://bugs.gentoo.org/721472
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-perl/Class-Accessor-0.100.0
+       >=dev-perl/Clone-0.150.0
+       >=dev-perl/String-Tokenizer-0.50.0
+"
+BDEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+       test? (
+               dev-perl/Test-Exception
+               virtual/perl-Test-Simple
+       )
+"
+PATCHES=(
+       "${FILESDIR}/${PN}-1.13-no-dot-inc.patch"
+)
diff --git a/dev-perl/CQL-Parser/files/CQL-Parser-1.13-no-dot-inc.patch b/dev-perl/CQL-Parser/files/CQL-Parser-1.13-no-dot-inc.patch
new file mode 100644 (file)
index 0000000..5a78340
--- /dev/null
@@ -0,0 +1,21 @@
+From 0713a497ad56e6b0ff939c277e87db46c7763091 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 8 May 2020 01:28:54 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 7c16d62..00324cb 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install 1.06;
+ if ( -e 'MANIFEST.SKIP' ) {
+-- 
+2.26.2
+